CertBot on Raspbian: "Illegal Instruction"


#1

Hi,

I’m trying to set up certbot for raspbian jessie. I install the package for Debian jessie-backports, but when I try to run it, I get the following:

$ letsencrypt --apache certonly
Illegal instruction

Do I have to compile from source?

Thanks!


#2

Have you tried replacing “letsencrypt” with “certbot”?

Mine worked (on Raspbian Stretch) with:

./certbot-auto --apache --rsa-key-size 4096

But I wouldn’t use the rsa-key-size option unless you were a masochist going for SSLLabs 100% scores…


Invalid certificate with Ubuntu 12.04 LTS (and No-IP with registered domain)
#3

Thanks! I had been using “letsencrypt” because I was following the instructions provided for Debian/wheezy rather than Debian/other. It turns out that running letsencrypt with sudo got rid of the “Illegal instruction” result, but still didn’t seem to work (or at least generated no output).

When I switched to the Debian/other instructions, which use certbot-auto, it popped up their nice ncurses interface and seems to work just fine. Thanks again!


#4

Also, you can’t use “certonly” with “–apache”. You’re not only getting a cert if you’re also asking it to adjust your Apache config! :wink:


#5

The plugins provide both authenticator and installer mechanisms, so it can make sense to use apache together with certonly – the apache plugin can be used for authentication purposes without using the corresponding installer.


#6

Oooh. I guess I should take my own advice when I tell people to RTFM :wink:


#8

odd…how did you all install the package via backports? I tried to install it and I still get “Illegal instruction” for any of the commands:

# certbot --help
Illegal instruction

# certbot --version
Illegal instruction

# certbot run
Illegal instruction

Any ideas on how to fix this?

Thanks!


#9

I am encountering exactly the same issue, on Raspbian Wheezy (Raspberry Pi Model B+).

# certbot-auto --apache

results in

# Illegal instruction

Anyone an idea how I get this fixed?

Thanks in advance.


#10

Okay, I figured out why I got an “Illegal instruction” failure. It was because the installed version of “libaugeas0” did not support ARMv6 (I am running a Raspberry Pi Model B+). I could solve this by following the instructions over here: https://github.com/certbot/certbot/issues/2673.

Everything working fine now and I have installed a Letsencrypt certificate on my Pi :-).