SOLVED: ERR_TOO_MANY_REDIRECTS on subdomain


#1

Hi guys

I searched this forum and google in general to solve this problem, but have not been able to solve it.
I just tried installing letsencrypt ssl on a new test-server that I’ve set up at Digital Ocean. It’s running Ubuntu 16.04.02 with apache2. This server is going to serve a testing/staging site for internal use. We are going to use a simple htaccess password protect to limit access to the site (but it’s not set up yet). Our production server is currently running on mydomain.tld with a ssl-certificate, which is why I’m only trying to set it up for our test site.

So I’ve tried setting up test.mydomain.tld (using a real domain ofc) subdomain with the command:
sudo letsencrypt --apache -d test.mydomain.tld

I picked the option to secure the whole site with ssl, and it said it’s successfully installed.

But when I try to go to either https://test.mydomain.tld or http://test.mydomain.tkd I get a ERR_TOO_MANY_REDIRECTS.

I can login to a root shell on my machine. So I could easily post my config files (this is my first time settting this up, so i’m a bit confused about the folders and files used for config, like /conf-available, /conf-enabled, /sites-available, and the corresponding files like 000-default.conf, 000-default-le-ssl.conf, default-ssl.conf).

Best regards, Kasper

** EDIT: The solution was to force ssl within prestashop settings. **


#2

hi @kasp1

without a domain name or some screenshots of troubleshooting you have done it’s not possible to assist

for example: have you tested multiple browsers?
have you used curl to see what happens when you request the domain (there may be a loop)

The list of tests that can be done is fairly exhaustive which is why you are asked for a domain name when requesting help (as people can run the tests with the tools they are comfortable with and provide you guidance on what might be happening)

Andrei


#3

Hi @ahaw021

Thanks for pointing it out :smile:

The domain i’m using is REMOVED

I’m running a prestashop install on this server, and just now I changed the prestashop settings to force ssl on all pages. This seems to work now, but prestashop is requesting images from insecure sources http://. This is not related to my first problem so actually I think I’m good now!


#4

Hi @kasp1

Yeah your SSL configs look good

The only thing that is letting you down (no green padlock) is some of the images are being served over HTTP not HTTPS

this site can help narrow these down: https://www.whynopadlock.com/check.php

Andrei


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.