[Solved]Creating wildcard using pfSense


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: varazir.wtf

I ran this command: using pfsense ACME pkg

/usr/local/pkg/acme/acme.sh --renew -d ‘*.varazir.wtf’ --yes-I-know-dns-manual-mode-enough-go-ahead-please --dns --home ‘/tmp/acme/varazir.wtf/’ --accountconf ‘/tmp/acme/varazir.wtf/accountconf.conf’ --force --reloadCmd ‘/tmp/acme/varazir.wtf/reloadcmd.sh’ --log-level 3 --log ‘/tmp/acme/varazir.wtf/acme_issuecert.log’

I have added a TXT record with Domain: _acme-challenge.varazir.wtf and the text I got from the output.

It produced this output:
[Wed Nov 14 15:26:10 CET 2018] *.varazir.wtf:Challenge error: {“type”:“urn:ietf:params:acme:error:malformed”,“detail”:“Unable to update challenge :: The challenge is not pending.”,“status”: 400}

My web server is (include version): pfSense 2.4.5

The operating system my web server runs on is (include version): FreeBSD 11.2-RELEASE-p4

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): yes
I manage my domain name at inviso.se

Didn’t understand that I hade to add the txt record and then run renew