SOLVED: Command not found

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:
certbot, and sudo cerbot

It produced this output:
command not found

My web server is (include version):
Apache/2.4.25 (Debian)

The operating system my web server runs on is (include version):
Debian 9 (I know, I will update soon)

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
-bash: certbot: command not found
-bash: certbot-auto: command not found

A little background, I have used certbot for years on my Debian server, without issue, always without problems kudos. The bad thing is, I am not really practiced in solving problems with Certbot. But, My certificate is not updating.
More critical, I can't find the certbot command =( I have used certbot (not certbot-auto, or letscrypt-auto, or anything, but certbot). It has always worked with altering, changing, or updating certificates, if I did any manually. All the automated ones worked perfectly as well.

I tried a locate, and found a "certbot" in my /usr/bin directory. But, in fact, it was not really there, I had to update my locate database. Once I did that, I had less references to certbot.

Then, I ran sudo find / -type f -name certbot 2>/dev/null, per reading another post on the topic on the forums, and got the following ouput:

But, my guess is that those are not the application for updating, etc??

I am guessing that over time, I must have updated, and things changed??

I am really at my wits end, and my email server, cloud, etc. are now funky. I have another certificate, with *.org in the end. Maybe I configured the last certificate wrong, as I want *.com to be the main certificate. But, the current situation is I cannot find certbot to fix things. =(

Thanks in advance, and thanks for reading if you made it this far.

EDIT: looking more closely, I think I falsely configured as the head of the certificate instead of .com..But, unfortunately I need it back to .com.

Well, it seems something or someone has removed certbot from your system. You probably can re-install certbot following the applicable guide on again.

Also, maybe you can run history | grep certbot to find out if there is an entry which removed certbot? Probably required to run as root, I dunno if sudo works for history as I think it's a Bash buildin function.


Whoa you scared me =) But, the history via root or sudo user show it being removed, at all. It just showed my recent searches for it, and my last command.

It looks good, the cert name should be "" which has apparently expired.

I guess I will just re-install certbot, and see how that goes.

1 Like

Just re-installing it seemed to work. I guess I use snap now.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.