[solved]Cant create certificate on one domain

I have 3 certificates that came out ok. This .com one having probs with.Or is there 3 cert limit? thought it was 5.

Any help appriciated. I upgraded all and gave out more probs…hopefully this post still understandable.

Should I start using ipv6 instead of ipv4 on my dns server?

Now after upgrade ran into another prob. Why does certbot add to http conf ?
IfModule mod_ssl.c>

ok, missing < as cant post them

just gives out this error now:
Error while running apache2ctl configtest.

AH00112: Warning: DocumentRoot [/var/lib/certbot/tls_sni_01_page/] does not exist
AH00526: Syntax error on line 236 of /etc/apache2/httpd.conf:
Cannot define multiple Listeners on the same IP:port

My domain is: www.framestorystudio.com

I ran this command: # certbot certonly -d www.framestorystudio.com

It produced this output: Failed authorization procedure. www.framestorystudio.com (tls-sni-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Connection refused


  • The following errors were reported by the server:

    Domain: www.framestorystudio.com
    Type: connection
    Detail: Connection refused

My web server is (include version): apache -> updated to

The operating system my web server runs on is (include version): # uname -a
Linux KiD3 4.11.8-1-default #1 SMP PREEMPT Thu Jun 29 14:37:33 UTC 2017 (42bd7a0) x86_64 x86_64 x86_64 GNU/Linux
updated to # uname -a
Linux KiD3 4.14.0-1-default #1 SMP PREEMPT Mon Nov 13 21:02:46 UTC 2017 (ab9e909) x86_64 x86_64 x86_64 GNU/Linux


My hosting provider, if applicable, is: Telia.fi (dont think it matters)

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no (only console)

adding a backslash before things that don't show in post usually fixes that.

There seem to be multiple problems:

  1. Somewhere DocumentRoot has been defined to a path (/var/lib/certbot/tls_sni_01_page/) that doesn't exist.
  2. Whatever is in line 236 of /etc/apache2/httpd.conf needs review
  3. In your vhost configs it's defining multiple listeners on same IP and port.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.