.solution and .app TLD disabling generation of certificate

My domain is: ichibod.app ichibod.solutions

I ran this command: sudo certbot --nginx

It produced this output:
An unexpected error occurred: The server will not issue certificates for the identifier :: Error creating new order :: Cannot issue for "ichibod.soltuions": Domain name does not end with a valid public suffix (TLD) Please see the logfiles in /var/log/letsencrypt for more details.

My web server is (include version): nginx 1.14.2

The operating system my web server runs on is (include version): Debian 10

My hosting provider, if applicable, is: Google Cloud Compute Engine

I can login to a root shell on my machine (yes or no, or I don't know): SUDO access, not root itself.

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 1.10.1

As an alternative trying to just get a certificate for ichibod.app I tried using the ACME.sh script with this command

acme.sh --issue -d ichibod.app -w ~./ichibod.app --log

'[Fri Dec 11 01:58:42 UTC 2020] Using CA: https://acme-v02.api.letsencrypt.org/directory [Fri Dec 11 01:58:42 UTC 2020] Single domain='ichibod.app' [Fri Dec 11 01:58:42 UTC 2020] Getting domain auth token for each domain [Fri Dec 11 01:58:43 UTC 2020] Getting webroot for domain='ichibod.app' [Fri Dec 11 01:58:43 UTC 2020] Verifying: ichibod.app [Fri Dec 11 01:58:46 UTC 2020] ichibod.app:Verify error:Invalid response from http://ichibod.app/.well-known/acme-challenge/5pJ2F7zmQXthkTiOVTYx0RMDn4982r1OPDi0Ddr_SdE []: [Fri Dec 11 01:58:46 UTC 2020] Please check log file for more details: /home/useruser/.acme.sh/acme.sh.log

1 Like

You mistyped the domain here. Look carefully at both your terminal command and also in your nginx configuration for the soltuions typo.

This webroot doesn't look right.

Did you mean to type (without the period):


What is the absolute path of the webroot, without any tilde (~)?


... A fresh pair of eyes is so helpful... Let me quickly adjust those things and report back. THANK YOU!


I fixed the typo in my nginx configuration and ran certbot again with success! THANK YOU! I had been staring at these things all day and I completed missed that typo!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.