Site stop working after install Cerbot


#1

I follow a tutorial to add ssl encrytpion to my site

I have Ubuntu/Apache/Joomla/Mysql

After instalation

IMPORTANT NOTES:

  • Congratulations! Your certificate and chain have been saved at:
    /etc/letsencrypt/live/esaof.edu.pt/fullchain.pem
    Your key file has been saved at:
    /etc/letsencrypt/live/esaof.edu.pt/privkey.pem
    Your cert will expire on 2019-05-28. To obtain a new or tweaked
    version of this certificate in the future, simply run certbot again
    with the “certonly” option. To non-interactively renew all of
    your certificates, run “certbot renew”

  • If you like Certbot, please consider supporting our work by:

    Donating to ISRG / Let’s Encrypt: https://letsencrypt.org/donate
    Donating to EFF: https://eff.org/donate-le

My domain is: esaof.edu.pt

sudo apache2ctl -S
AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1. Set the ‘ServerName’ directive globally to suppress this message
VirtualHost configuration:
*:443 esaof.edu.pt (/etc/apache2/sites-enabled/000-default-le-ssl.conf:2)
*:80 127.0.1.1 (/etc/apache2/sites-enabled/000-default.conf:1)
ServerRoot: “/etc/apache2”
Main DocumentRoot: “/var/www/html”
Main ErrorLog: “/var/log/apache2/error.log”
Mutex ssl-stapling: using_defaults
Mutex ssl-cache: using_defaults
Mutex default: dir="/var/run/apache2/" mechanism=default
Mutex mpm-accept: using_defaults
Mutex watchdog-callback: using_defaults
Mutex rewrite-map: using_defaults
Mutex ssl-stapling-refresh: using_defaults
PidFile: “/var/run/apache2/apache2.pid”
Define: DUMP_VHOSTS
Define: DUMP_RUN_CFG
User: name=“www-data” id=33
Group: name=“www-data” id=33

The site is down, I have to reverse the cerbot process or put it working, please help


#2

You have installed a redirect from HTTP to HTTPS. This redirect on port 80 is working fine, so your webserver is running properly. But for some reason, a client can’t connect to port 443 on the IP address of esaof.edu.pt (193.236.42.78).

Do you have a firewall or router blocking port 443? Opening port 443 is mandatory for normal HTTPS operation.


closed #3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.