Server not using installed Certbot certificate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: Everything from:

It produced this output: Installed cerificate, but not using it.

My web server is (include version): Cloud Server

The operating system my web server runs on is (include version): CentOS 7.5

My hosting provider, if applicable, is: Neostrada | Powered by

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): DirectAdmin

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.38.0

EDIT: It’s currently using a self signed certificate.

Hi @Cookooloo

that's too unspecific. The first part is the installation. But what was your certificate creation command?

And checking your domain you have created the wrong certificate -

Issuer not before not after Domain names LE-Duplicate next LE
Let's Encrypt Authority X3 2019-09-26 2019-12-25 - 1 entries duplicate nr. 1

The certificate has only one domain name, not two.

So first step: What says

apachectl -S
1 Like


The commands I ran:

yum install epel-release
yum -y install yum-utils
yum-config-manager --enable rhui-REGION-rhel-server-extras rhui-REGION-rhel-server-optional
sudo yum install certbot
sudo certbot certonly --webroot

Also, I ran apachectl -S and it gives me a lot of information.
I’ll type it out and edit this post.

apachectl -S:

default server localhost
namevhost localhost

all of these have 2 entries, with port 80 and port 443.

Do I need to add more?


your answer. certonly doesn't create a port 443 vHost and doesn't install a certificate.

Last step: Use

sudo certbot -d -d --apache


But first your vHost configuration is required to see, if you have a correct port 80 vHost with both domain names.

1 Like


Does this also get the subdomain?


The requested apache plugin does not appear to be installed

Please read

Hi @JuergenAuer,

I tried some more steps but I’m getting a new error now:

sudo certbot -d -d --apache


The apache plugin is not working; there may be problems with your existing configuration.
The error was: MisconfigurationError(‘Error while running apachect1 configtest.\n\nhttpd: Syntax error on line 52 of /etc/httpd/conf/httpd.conf : Syntax error on line 6 of /etc/httpd/conf/extra/httpd-phpmodules.conf : Cannot load /usr/lib/apache/ into server: /usr/lib/apache/ indefined symbol: ap_set_listencbratio\n’,)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.