Server at Azure VM with Nginx on Windows 10

Hello everyone,
As we know that Certbot is not supporting auto config for Nginx yet on Windows.
I have created and got successfully my PEM file, and i have reconfigured my Nginx Configuration file manually.
However, my domain is still not secured. I can successfully access my domain without certificate configuration, but once i configured it to use certificate.. i can't reach my domain with time out message.

Here are my domain details.

My domain is:

I ran this command on Certbot: Certbot certonly --standalone

Certbot produced the PEM file and stored inside my C:/ drive outside my nginx folder.

Here is my nginx configuration:

    server {    
    listen       80 ssl;
    ssl on;
    ssl_certificate      C:/......./fullchain.pem;
    ssl_certificate_key  C:/......./privkey.pem;
    ssl_session_cache    shared:SSL:50m;
    ssl_session_tickets off;
    ssl_session_timeout  1d;
    ssl_protocols TLSv1.2;
    ssl_ciphers  'xxxxxxx-hidden-xxx';
    ssl_prefer_server_ciphers  on;
    keepalive_timeout  60;
    limit_req zone=limit_req_per_ip burst=1000 nodelay;
    set $public_site             ...;
    set $path_htpasswd          ....;
    set $errors_pages           std_errors;

    # Default Web site

    location / {
        root   $public_site;
        index  index.html
        try_files $uri$args $uri$args/ /nodered/$uri$args;

        add_header "X-Frame-Options" "SAMEORIGIN";
        add_header "Access-Control-Allow-Methods" "GET, OPTIONS, HEAD";
        add_header "Access-Control-Allow-Headers" "Authorization, Origin, X-Requested-With, Content-Type, Accept";
        add_header  Cache-Control must-revalidate always;

This needs to be listen 443 ssl; and you need to make sure port 443 is open on the Windows and Azure firewalls.

Thanks. Is it not possible to use port 80 for ssl ? i read on some references.. it shall be OK.

Thankz @_az ! It is solved now, i can use another port rather than 443 but shall be not 80. Because i use unstandardized port then i must specify the port in browser:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.