Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: certbot --apache

It produced this output:
Firefox and edge both report unknown issuer on certificate (It is using the fullchain.pem)

My web server is (include version): apache 2.4.37-43

The operating system my web server runs on is (include version): centos stream 8 (current release)

My hosting provider, if applicable, is: na

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 1.21.0

1 Like

Welcome to the Let's Encrypt Community, Mike :slightly_smiling_face:

The two-certificate chain I see being served for over port 443 consists of two self-signed (snake oil) certificates. It does not appear that the Let's Encrypt certificate chain issued two hours ago is actually installed in your Apache configuration.


Ah, I see the problem the conf.d/ssl.conf file still had the default entries. Apparently the --apache option doesn't update that file.

I'm getting a valid certificate now.

1 Like

You don't need to acquire another certificate. You just need to install the one you have into Apache.

I can help you with that if you wish.

What are the outputs of:

sudo apachectl -S
sudo ls -lRa /etc/apache2

Please put 3 backticks above and below each output, like this:


Certbot usually expects custom Apache VirtualHosts to be in separate configuration files rather than the default configuration files.


Sorry, what I meant was that the browser is showing a valid certificate now.

Apparently apache uses the data in conf.d/ssl.conf over the data in conf/httpd-le-ssl.conf


Apache will use the first definition for an ip:port:hostname combination. That's why it's important to check sudo apachectl -S for conflicts.


Ah. That makes sense. Yep. Looks good now!



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.