Revoking a certificate (stupid version)


#1

I was following this tutorial: http://www.cyberciti.biz/faq/how-to-configure-nginx-with-free-lets-encrypt-ssl-certificate-on-debian-or-ubuntu-linux/,
and it worked: I had my https site online.

But then I decided to redo the tutorial with other settings, so I cleaned up (rm) everything and started back again, forgetting that certificates are sensitive things.

From my editor history, I can access to the certificate code:

-----BEGIN CERTIFICATE-----
MIIGKTCCBRGgAwIBAgISAbecA+qHw6ouRkKY9rzmikPWMA0GCSqGSIb3DQEBCwUA

-----END CERTIFICATE-----

But that’s pretty much all I have left.
Redoing the tutorial gets me to the point where I do this command

le issue /var/www/html theos.in www.theos.in 4096

(le is the name of the script used in the tutorial)
I get the following error:

Verify error:Error parsing key authorization file: Invalid key authorization: malformed token

I’m not sure what I should do at that point.
Revoking the offending certificate (but how?) and create a new one?


#2

Since you are using le you should really ask @Neilpang, the author of that specific script.

I don’t think revoking the current certificate will make any difference with that error - so no I wouldn’t try and revoke it ( especially if you don’t have the private key anyway)

The error looks to be with the token which would be placed in theos.in/.well-known/acme-challenge/xxx


#3

yes, in case you removed everything. you just need to issue a new one.
Just start from the beginning, and issue again.

No need to revoke.


#4

Thanks, it worked. Actually, I was pointing the script on the wrong application (so stupid, how could I not see that…).