Retrieved the wrong certificate?


#1

Hi,

I’m making some test for an unused domain, and I think i’m retrieving a certificate for another domain (that I don’t own).

First of all i’ve install letsencrypt script on my mac, tried to issue a certificate for my domain (not verified at that time), and for a subdomain (srweb.info and www.srweb.info), it returned an error about a domain verification failed BUT talked about my 2 domains and another domain that i don’t own (editions.aurelienpierre.com), really weird…

First command : ./letsencrypt-auto --agree-dev-preview --server acme-v01.api.letsencrypt.org/directory certonly
Return : Failed authorization procedure. srweb.info (tls-sni-01): urn:acme:error:unauthorized :: The client lacks sufficient authorization :: Correct zName not found for TLS SNI challenge. Found editions.aurelienpierre.com, aurelienpierre.com

After that i’ve tried to verify my domain throught that command :
./letsencrypt-auto certonly -a manual -d srweb.info --server acme-v01.api.letsencrypt.org/directory --agree-dev-preview

Successfully verified my domain, and retrieved certificate and pkey.

Tried to install on my webserver, it says that my certificate is associated with editions.aurelienpierre.com (you can try by visiting https://srweb.info)

Am I wrong or did i’ve retrieved a wrong certificate ?

Thanks for your help,

Sylvain


#2

ssl on editions.aurelienpierre.com

Common Name (CN) StartCom Class 1 Primary Intermediate Server CA
Organization (O) StartCom Ltd.
Organizational Unit (OU) Secure Digital Certificate Signing
Validity Period

that not from LE, you on shared hosting?


#3

yeah, you’re right, i’ll check with my provider, my bad :confused: