Renovar certificado

Buenos días, tengo un error al intentar renovar mi certificado para homeassistant. Cuando intento renovarlo me sale el siguiente error.

My domain is:

I ran this command: renovar certificado con addon duckdns

It produced this output:

  • Checking domain name(s) of existing cert... unchanged.
  • Checking expire date of existing cert...
  • Valid till Dec 7 14:32:49 2020 GMT Certificate will expire
    (Less than 30 days). Renewing!
  • Signing domains...
  • Generating private key...
  • Generating signing request...
  • Requesting new certificate order from CA...
  • ERROR: An error occurred while sending head-request to (Status 000)
    ERROR: Problem connecting to server (post for; curl returned with 6)

My web server is (include version): hassos

No sé cómo renovar para volver a tener acceso https.
[]: 404
Al renovar. El puerto 80 me dice el equipo que está ocupado por lo que lo hago con otro puerto.

1 Like

Your firewall may be blocking the outbound HTTPS request.

1 Like

Buenas, no puedo regularizar mis certificados caducados. Del sitio
Al levantar el addon me sale el error:

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] done.
[services.d] starting services
[services.d] done.

INFO: Using main config file /data/workdir/config

ERROR: Problem connecting to server (get for; curl returned with 7)
[cmd] / exited 1
[cont-finish.d] executing container finish scripts...
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.

Y cuando intento renovarlo me sale:

1 Like

Login to your server and try:


respuesta a la ultima ejecucion del comando
curl (6) no resolve host
anteriormente me ha salido informacion sobre diversas url

1 Like

Then you may have a DNS problem, try:

Show this:
cat /etc/resolv.conf

1 Like

c'ant find acme....
el segundo comando:
name server
options ndots:0
estas son las respuestas
puede existir algo relacionado con el router? acutalmente redirecciono el 443 al 8123 y el 80 al 80.
cuando intento la renovacion por el addon me sale que el puerto 80 está ocupado.
ping a mi dominio correcto. hay problema de renocacion de certificado. desconozco el procedimiento correcto

1 Like

One step at a time.
First, we fix DNS.
Try these:

1 Like

Existen respuestas a los comandos
perdon pero soy muy novato en el tema.
el sistema es una raspberry pi que ejecuta hassio.

1 Like

The picture is too small to read clearly.
But looks like DNS works when using external global DNS systems.
Please show all of (if more was there than you already showed above):
cat /etc/resolv.conf

If same as above, try changing the nameserver line to:

[and save the file]

1 Like

sorry. the picture:

1 Like

No problem.
That is what I thought it showed :slight_smile:
Edit the file and try again:

1 Like

the 1 picture

perdon pero no se como editar el archivo indicado en el comentario

respuesta de curl

That screenshot is confusing me.
The first curl command fails, and then works immediately following that line.
Then it fails again three more times.
Even nslookup fails.
I don't understand how it worked that one time.

To edit the file you need to learn how to use an editor.
But the file is privileged so you have to edit it as root user.
sudo editor /etc/resolv.conf
sudo vi /etc/resolv.conf

the first entry is a mistake of mys. then if there is a response to the curl command. regarding editing the file I need some help. and know which file name I should edit. I appreciate your patience

You can use nano editor or vi editor with root privileges as:
sudo editor /etc/resolv.conf
sudo vi /etc/resolv.conf


and save the file and exit the editor

1 Like

it should contain the file since I think I've loaded it content from the screen
me funciona vi pero no se moverme con sus comandos. creo que he corrompido el contenido del archivo con elementos de la pantalla

Close that the Terminal.
Open a new Terminal.
Issue these commands in the Terminal window:
sudo rm /etc/resolv.conf
sudo echo 'nameserver' > /etc/resolv.conf

then show it with
cat /etc/resolv.conf

1 Like

ahora me sale nuevamente el error que no resuelve curl

^^^ read my last post ^^^