Renewal fails only for one website

I have a vm with 2 websites: and, with nginx.
telefoni is expired, and I tried to renew it with certbot renew command: it renewed welcome but not telefoni, I tried also with the command certbot certonly -d, but nothing, here is the log:

2023-05-10 15:25:04,875:DEBUG:urllib3.connectionpool: "POST /acme/finalize/613312366/181335233297 HTTP/1.1" 503 90
2023-05-10 15:25:04,876:DEBUG:acme.client:Received response:
HTTP 503
Server: nginx
Date: Wed, 10 May 2023 15:25:04 GMT
Content-Type: application/problem+json
Content-Length: 90
Connection: keep-alive
Cache-Control: private
Retry-After: 28

{"type": "urn:ietf:params:acme:error:rateLimited", "detail": "Service busy; retry later."}
2023-05-10 15:25:04,876:DEBUG:certbot._internal.log:Exiting abnormally:
Traceback (most recent call last):
  File "/snap/certbot/3024/bin/certbot", line 8, in <module>
  File "/snap/certbot/3024/lib/python3.8/site-packages/certbot/", line 19, in main
    return internal_main.main(cli_args)
  File "/snap/certbot/3024/lib/python3.8/site-packages/certbot/_internal/", line 1864, in main
    return config.func(config, plugins)
  File "/snap/certbot/3024/lib/python3.8/site-packages/certbot/_internal/", line 1597, in certonly
    lineage = _get_and_save_cert(le_client, config, domains, certname, lineage)
  File "/snap/certbot/3024/lib/python3.8/site-packages/certbot/_internal/", line 141, in _get_and_save_cert
    lineage = le_client.obtain_and_enroll_certificate(domains, certname)
  File "/snap/certbot/3024/lib/python3.8/site-packages/certbot/_internal/", line 517, in obtain_and_enroll_certificate
    cert, chain, key, _ = self.obtain_certificate(domains)
  File "/snap/certbot/3024/lib/python3.8/site-packages/certbot/_internal/", line 451, in obtain_certificate
    cert, chain = self.obtain_certificate_from_csr(csr, orderr)
  File "/snap/certbot/3024/lib/python3.8/site-packages/certbot/_internal/", line 341, in obtain_certificate_from_csr
    orderr = self.acme.finalize_order(
  File "/snap/certbot/3024/lib/python3.8/site-packages/acme/", line 275, in finalize_order
  File "/snap/certbot/3024/lib/python3.8/site-packages/acme/", line 226, in begin_finalization
    res = self._post(orderr.body.finalize, wrapped_csr)
  File "/snap/certbot/3024/lib/python3.8/site-packages/acme/", line 366, in _post
    return*args, **kwargs)
  File "/snap/certbot/3024/lib/python3.8/site-packages/acme/", line 739, in post
    return self._post_once(*args, **kwargs)
  File "/snap/certbot/3024/lib/python3.8/site-packages/acme/", line 752, in _post_once
    response = self._check_response(response, content_type=content_type)
  File "/snap/certbot/3024/lib/python3.8/site-packages/acme/", line 603, in _check_response
    raise messages.Error.from_json(jobj)
acme.messages.Error: urn:ietf:params:acme:error:rateLimited :: There were too many requests of a given type :: Service busy; retry later.
2023-05-10 15:25:04,877:ERROR:certbot._internal.log:An unexpected error occurred:
2023-05-10 15:25:04,877:ERROR:certbot._internal.log:Service busy; retry later.

any help?
thanks a lot

Probably some performance issues at Let's Encrypts side, nothing particular you can do about except from trying again later as instructed in the error message.


Switch to another free CA [if you need a cert right away].


thank you guys, actually after a little time it worked!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.