Renew: Place Webroot Path in Config File


#1

Hey,

I’m running certbot on Debian 8 (0.6.0). I have set up the first domain using the client with the webroot method. Anyhow, when i run the certbot renew command I get this message:

2016-06-07 09:27:38,138:WARNING:certbot.renewal:Attempting to renew cert from /etc/letsencrypt/renewal/xxx.conf produced an unexpected error: Missing command line flag or config entry for this setting:
Select the webroot for xxx:
Choices: ['Enter a new webroot']

(You can set this with the --webroot-path flag). Skipping.

My idea was now to set the webroot path in the config file of every domain in /etc/letsencrypt/renewal/ like the error states above. But somehow this does not work. What is the correct way to do that?

Thanks


#2

Hi @phluko, do you remember what command you used to get the certificate originally?

Was it the same version of certbot that you’re using now?

Are there any references to webroot in the renewal configuration file?


#3

Hi @schoen

I’ve used certbot certonly and ./certbot-auto certonly (from the repo or direct download. Using the same version to renew the certificate then using certbot renew --dry-run or ./certbot-auto renew --dry-run.

This is part of the config file:

# Options used in the renewal process
[renewalparams]
authenticator = webroot
installer = None
account = xxx

Tried to create and renew a new certificate now with certbot 0.8.0, but same thing happens


#4

@phluko, did you originally specify a webroot with your certonly command using -w or --webroot-path?

Is there absolutely no reference now to webroot_path or webroot_map in the [renewalparams] section of your config file?


#5

Nope - did specify nothing at the command level, did use the “graphical” interface and entered the webpath there.

Added webroot_path now to the config, works now - thanks. Should be added in the documentation somewhere, or the client should write the entered path in the config I guess.

Thanks for the help!


#6

@phluko, I do think what you’ve encountered is a bug because the webroot_path that you entered originally should have been saved automatically and re-used. I’m curious whether it was saved and then got removed later, or whether it was never saved at all. Of course, that’s hard for you to confirm at this point.

I’ll make a note to try an experiment and see if I can reproduce the problem from what you’ve described.

I’m glad that adding webroot_path manually worked for you, though.


#7

Hey I’m having this issue as well, and I can’t seem to figure out how to manually add it to the config file either. I attemped

./certbot-auto --webroot-path /path/to/webroot

But I got an error:

No installers seem to be present and working on your system; fix that or try running certbot with the "certonly" command


#8

@JBourne, it needs to be something like ./certbot-auto certonly --webroot-path /path/to/webroot -d domain1.example.com -d domain2.example.com (there has to be a verb, which for the renewal case should be certonly).


#9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.