Renew failed: SERVFAIL looking up CAA


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: https://subdomain.awsmppl.com

I ran this command:

certbot renew

or

certbot certonly --webroot -w /var/lib/letsencrypt/ -d subdomain.awsmppl.com

(ArchWiki)

It produced this output:

Domain: subdomain.awsmppl.com
Type: connection
Detail: DNS problem: SERVFAIL looking up CAA for subdomain.awsmppl.com

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A/AAAA record(s) for that domain
contain(s) the right IP address. Additionally, please check that
your computer has a publicly routable IP address and that no
firewalls are preventing the server from communicating with the
client. If you’re using the webroot plugin, you should also verify
that you are serving files from the webroot path you provided.

My web server is (include version): Apache

The operating system my web server runs on is (include version): Archlinux 32bits

My hosting provider, if applicable, is: self-hosted

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no.

Thank you!
My certificate will expire in 7 days and I really need my server for my work.


#2

I think that something is not working with your DNSSEC. I’m not any kind of expert, but it looks like your NSEC mechanism is not working, which is used to authenticate that a DNS record doesn’t exist. I think this is a problem with the authoritative nameservers (nova53) for your domain.

You might be able to work around this by adding an actual CAA record to your domain, bypassing the NSEC problem.

These resources might help you:

Another potential workaround may be to disable DNSSEC for this domain at your registrar entirely, since it is malfunctioning anyway.


#3

I"m not certain, but someone should try running “pdnsutil rectify-zone awsmppl.com” on the DNS server(s). (And ensure that all of the zones are always properly rectified now and in the future.)

Edit: I’m pretty certain.


#4

Solved!
It was a problem with DNSSEC.
I contacted the admins and they fixed it.
Thank you a kot for your help!


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.