Renew, but only updated fullchain & expiry date not changed,


#1

Please fill out the fields below so we can help you better.

My domain is: regal.netframe.io

I ran this command: sudo ./certbot-auto renew

It produced this output:

Congratulations, all renewals succeeded. The following certs have been renewed:
/etc/letsencrypt/live/regal.netframe.io/fullchain.pem (success)

My operating system is (include version): AWS Linux

My web server is (include version): Node

My hosting provider, if applicable, is: AWS

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): ?


#2

Did you reload/restart the webserver?


#3

The WebServer is a Node App, so I ran a WebRoot app to deal with the Challenge Response, copied the fullchain.pem to my /keys directory and then restarted my main (SSL) app. What I don’t get is previously certbot would issue a key set, comprising of cert.pem, chain.pem, privkey.pem & fullchain.pem, but on this occasion I only got fullchain.pem.


#4

It should provide all four. Perhaps the output of the program only mentions the fullchain.pem (because that’s the file people would be using), but every symbolic link to the actual most recent files should be there in /etc/letsencrypt/live/.


#5

You are absolutely right…just updated all keys & now fine. Thanks for your assistance.


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.