Remove duplicate certificate

I ran certbot --apache initially and it failed. I changed the setup to fix an issue, and ran certbot --apache again. This time it worked, but now I have two sets of certificates:
lyricproof.com and lyricproof.com-0001.

How do I remove the duplicate certificate (lyricproof.com-0001)? I've tried both of the following commands but neither worked with what I was attempting:

certbot delete lyricproof.com-0001
certbot deactivate lyricproof.com-001

What's the best way to remove the duplicate?

My domain is: lyricproof.com

I ran this command: certbot --apache (twice)

It produced this output: NA

My web server is (include version): Apache

The operating system my web server runs on is (include version): Ubuntu 20.04

My hosting provider, if applicable, is: NA

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 1.16.0

2 Likes

Welcome to the Let's Encrypt Community :slightly_smiling_face:


First, check your apache configuration files starting with:

sudo apachectl -S

to ensure that you're not using the lyricproof.com-001 certificate. You may need to run:

sudo certbot certificates

to ensure that the lyricproof.com certificate covers the domain names that you want.


Second, delete the lyricproof.com-001 certificate with:

sudo certbot delete --cert-name lyricproof.com-001


Third, are you sure you don't need a certificate covering both lyricproof.com and www.lyricproof.com?

sudo certbot --cert-name lyricproof.com --apache -d "lyricproof.com,www.lyricproof.com"


Complete certificate history for lyricproof.com:

https://crt.sh/?q=lyricproof.com

2 Likes

Thank you! sudo certbot delete --cert-name lyricproof.com-0001 did the trick!

The first lyricproof.com from today covered the domain names I needed. (It looks like today's certificates haven't shown up in the certificate history yet.)

3 Likes

I really think you need that certificate covering both the apex and www:

2 Likes

I kept the certificate that covers www. I just need to fix the server set up. Found the following certs:

  Certificate Name: lyricproof.com
    Serial Number: 4a5d138759a8e240ae603242d01f406c2cb
    Key Type: RSA
    Domains: lyricproof.com cloud.lyricproof.com www.lyricproof.com
    Expiry Date: 2021-09-18 22:14:50+00:00 (VALID: 89 days)
    Certificate Path: /etc/letsencrypt/live/lyricproof.com/fullchain.pem
    Private Key Path: /etc/letsencrypt/live/lyricproof.com/privkey.pem
2 Likes

Maybe reload apache?

sudo apachectl -k graceful

2 Likes

These should also 301 redirect to https rather than failing:

http://www.lyricproof.com
400 Bad Request

http://cloud.lyricproof.com
400 Bad Request

You can test your redirects with:

redirect-checker.org

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.