RemoteCertificateNameMismatch on port 993

My domain is

What is wrong with certificate made by certbot --webroot?
I’m trying to create mail server, but I have problem with SSL certificate. I copied fullchain1.pem and privkey1.pem to my postfix and dovecot configurations. I restarted them. When I create account in Thunderbird and I want to connect to server I see:


I am going with this tutorial:

Why IMAP has problem with Letsencrypt certificate?

Hi @gongarek

that's not a problem, that's the ip address. There the certificate is always wrong.

Your connections are correct:

The ip address is checked. But if it is a valid Letsencrypt certificate, the certificate has a domain name -> so the ip address has a certificate with the wrong name. But that's not a problem.

1 Like

To connect to “”, you need a certificate for “”, not just “”.

Since they’re currently running on the same server, you could configure your mail software to connect to “” instead.

You can also get a certificate for “”, with a command like “sudo certbot certonly --webroot -w /var/www -d -d -d”, or whatever options you used to create the certificate that exists now.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.