Really Simple SSL

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: www.beamsbuildinginspections.com.au

I ran this command:
followed everything in this video by aws https://www.youtube.com/watch?v=uwYH83OFGTo

It produced this output:
When is came to last part of installing really simple sll it won’t work.

My web server is (include version): linux apache2 aws lightsail setup

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Hi @TaylorK

checking your domain - https://check-your-website.server-daten.de/?q=beamsbuildinginspections.com.au - there is a valid and new wildcard certificate. So that works.

Only problem (but it’s not really a problem): Your www doesn’t have an A- or AAAA-record.

Host T IP-Address is auth. ∑ Queries ∑ Timeout
beamsbuildinginspections.com.au A 3.106.66.30 Sydney/New South Wales/Australia (AU) - Amazon Technologies Inc. Hostname: ec2-3-106-66-30.ap-southeast-2.compute.amazonaws.com yes 1 0
AAAA yes
www.beamsbuildinginspections.com.au Name Error yes 1 0

So you can’t use your www version, but your non www version works.

Grade H, so no redirect http -> https, but the https row has a Grade B, so the certificate is valid.

And you have already created 3 identical certificates.

Issuer not before not after Domain names LE-Duplicate next LE
Let’s Encrypt Authority X3 2020-05-05 2020-08-03 *.beamsbuildinginspections.com.au, beamsbuildinginspections.com.au - 2 entries duplicate nr. 3
Let’s Encrypt Authority X3 2020-05-05 2020-08-03 *.beamsbuildinginspections.com.au, beamsbuildinginspections.com.au - 2 entries duplicate nr. 2
Let’s Encrypt Authority X3 2020-05-05 2020-08-03 *.beamsbuildinginspections.com.au, beamsbuildinginspections.com.au - 2 entries duplicate nr. 1
1 Like

Hi Osiris,
Yes its interesting as I follow exactly the same steps for another website, precisely and it worked… Okay if you can refer a link to a recommended source following steps that a bulletproof that would be helpful . I do get all the way to the end when congratulations you have obtained the certificate, then I chmod on the wp config file to allow access using really simple ssl and it doesn’t work for me on this occasion.

Ahh yes I see, awesome so do I change that somehow in the dns settings?

Hi JeurgenAuer, please find the following website address, www.househornet.com.au, I went to the configuration in light sail and it looks identical , how would one change the requirements you mentioned regarding the “www”

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.