Problems with python

I am using the current Arch Linux on my root machine of hetzner.de . When i try to renew / certonly with certbot it gets stuck and throws this error after closing it with “ctrl + c” :

Traceback (most recent call last):
File “/usr/bin/certbot”, line 11, in
load_entry_point(‘certbot==0.19.0’, ‘console_scripts’, ‘certbot’)()
File “/usr/lib/python3.6/site-packages/certbot/main.py”, line 861, in main
return config.func(config, plugins)
File “/usr/lib/python3.6/site-packages/certbot/main.py”, line 797, in renew
renewal.handle_renewal_request(config)
File “/usr/lib/python3.6/site-packages/certbot/renewal.py”, line 425, in handle_renewal_request
main.renew_cert(lineage_config, plugins, renewal_candidate)
File “/usr/lib/python3.6/site-packages/certbot/main.py”, line 741, in renew_cert
le_client = _init_le_client(config, auth, installer)
File “/usr/lib/python3.6/site-packages/certbot/main.py”, line 486, in _init_le_client
return client.Client(config, acc, authenticator, installer, acme=acme)
File “/usr/lib/python3.6/site-packages/certbot/client.py”, line 235, in init
acme = acme_from_config_key(config, self.account.key)
File “/usr/lib/python3.6/site-packages/certbot/client.py”, line 45, in acme_from_config_key
return acme_client.Client(config.server, key=key, net=net)
File “/usr/lib/python3.6/site-packages/acme/client.py”, line 71, in init
self.net.get(directory).json())
File “/usr/lib/python3.6/site-packages/acme/client.py”, line 654, in get
self._send_request(‘GET’, url, **kwargs), content_type=content_type)
File “/usr/lib/python3.6/site-packages/acme/client.py”, line 627, in _send_request
response = self.session.request(method, url, *args, **kwargs)
File “/usr/lib/python3.6/site-packages/requests/sessions.py”, line 508, in request
resp = self.send(prep, **send_kwargs)
File “/usr/lib/python3.6/site-packages/requests/sessions.py”, line 618, in send
r = adapter.send(request, **kwargs)
File “/usr/lib/python3.6/site-packages/requests/adapters.py”, line 440, in send
timeout=timeout
File “/usr/lib/python3.6/site-packages/urllib3/connectionpool.py”, line 601, in urlopen
chunked=chunked)
File “/usr/lib/python3.6/site-packages/urllib3/connectionpool.py”, line 346, in _make_request
self._validate_conn(conn)
File “/usr/lib/python3.6/site-packages/urllib3/connectionpool.py”, line 850, in _validate_conn
conn.connect()
File “/usr/lib/python3.6/site-packages/urllib3/connection.py”, line 284, in connect
conn = self._new_conn()
File “/usr/lib/python3.6/site-packages/urllib3/connection.py”, line 141, in _new_conn
(self.host, self.port), self.timeout, **extra_kw)
File “/usr/lib/python3.6/site-packages/urllib3/util/connection.py”, line 73, in create_connection
sock.connect(sa)
KeyboardInterrupt

I am using uncomplicated firewall (ufw) but the ports of 80 and 443 are open to receive traffic.

What am i doing wrong?

Are you also allowing outgoing traffic on port 443?

Yes. Incoming aswell as outgoing traffic is allowed.

Apparently the process is just very very slow. But it seems to be working. Sorry for the inconvenience.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.