Problems running on Debian jessie


#1

Please fill out the fields below so we can help you better.

My domain is: not relevant

I ran this command: certbot

It produced this output:

An unexpected error occurred:
ValueError: Entry points must be listed in groups
Please see the logfile ‘certbot.log’ for more details.

My operating system is (include version):
Linux Debian 8 (jessie)

My web server is (include version):
not relevant (Apache 2)

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):
yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
no


certbot.log file holds these information:
Traceback (most recent call last): File "/usr/bin/certbot", line 9, in <module> load_entry_point('certbot==0.8.1', 'console_scripts', 'certbot')() File "/usr/lib/python2.7/dist-packages/certbot/main.py", line 700, in main plugins = plugins_disco.PluginsRegistry.find_all() File "/usr/lib/python2.7/dist-packages/certbot/plugins/disco.py", line 173, in find_all for entry_point in entry_points: File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 706, in iter_entry_points entries = dist.get_entry_map(group) File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2577, in get_entry_map self._get_metadata('entry_points.txt'), self File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2311, in parse_map raise ValueError("Entry points must be listed in groups")

I’m completely lost here, I don’t have any knowledge about python. I installed certbot as described on eff.org (Apache2, Debian 8; backports repository for jessie). Anyone here who could shed some light on this?


Update:
Even trying to do a “manual” install with “certbot-auto” from eff.org, like described on github, failed with
SystemError: Bad call flags in PyCFunction_Call. METH_OLDARGS is no longer supported!

So I think maybe my python version (2.7.9) is too young for letsencrypt?!

Regards,
VerboEse


#2

I don’t believe the problem is the version - though you can install python3.4 from the standard jessie repositories (if the developer docs are up-to-date python3 is not yet supported by certbot). According to the requirements certbot uses your version of python. Note that cerbot is beta.
I didn’t use certbot to install letsencrypt, but I am running Debian Jessie (without backports) so letsencrypt will install fine on a stock Jessie.

You could either:-

  • install the version of certbot from Jessie backports (as root) echo “deb http://ftp.debian.org/debian/ jessie-backports main contrib non-free” >> /etc/apt/sources.list;apt-get update;apt-get -yt jessie-backports letsencrypt
  • check that you have no package errors (as root apt-get -sf install|more), if errors exist fix them (as root apt-get -f install), and then/or reinstall python and see if it fixes the broken certbot python package (as root apt-get --reinstall install python2.7), then reinstall certbot, if problems still persist post the relevant lines from the errors (use nano -c $filename to find the relevant line) and readers may be able to help. If you choose that option I’d suggest you post the details to GitHub

#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.