Problems getting certificate for two DNS

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: elvenware.com, elven.work

I ran this command: sudo certbot --nginx

It produced this output: Which names would you like to activate HTTPS for?
We recommend selecting either all domains, or all domains in a VirtualHost/server block.


1: elven.work
2: www.elven.work
3: www.elvenare.com
4: elvenware.com


Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter 'c' to cancel):
Requesting a certificate for elven.work and 3 more domains

Certbot failed to authenticate some domains (authenticator: nginx). The Certificate Authority reported these problems:
Domain: www.elvenare.com
Type: dns
Detail: DNS problem: NXDOMAIN looking up A for www.elvenare.com - check that a DNS record exists for this domain; DNS problem: NXDOMAIN looking up AAAA for www.elvenare.com - check that a DNS record exists for this domain

Hint: The Certificate Authority failed to verify the temporary nginx configuration changes made by Certbot. Ensure the listed domains point to this nginx server and that it is accessible from the internet.

Some challenges have failed.
Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

My web server is (include version): nginx/1.18.0 (Ubuntu)

The operating system my web server runs on is (include version): Distributor ID: Ubuntu
Description: Ubuntu 22.04.4 LTS
Release: 22.04
Codename: jammy

My hosting provider, if applicable, is: aws ec2

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 2.9.0

I can create a certificate for elven.work. But when I tried to create it for all 4 URLS, the command failed as shown above. After trying all 4, I tried again asking only for the two associated with elven.work. That succeeded. But now I'm set up to work with only half my urls, and elvenware.com is more important than elven.work.

So I have two questions. Why does it succeed for elven.work and fail for elvenware.com? What is the best way to add elvenware.com assuming I can get it to work.

I called up network solutions to ask if I had filled in the A record for elvenware.com correctly and they assured me that I had.

this works

this doesn't.

www. is a different domain, you should add an A and/or AAAA record as desired.

4 Likes

Thank you so much. The problem was a typo. I meant to write www.elvenware.com but wrote www.elvenare.com, leaving out the W.

You caught the problem and my brilliant wife caught the problem, but I totally missed it. So I corrected the typo, then ran the command again, and now it works. I'm happy!

Thank you so much for your help.

5 Likes