Problema al renovar un certificado

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: facturar.vicens.com

I ran this command: certbot

It produced this output:

Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter 'c' to cancel): 14
Requesting a certificate for facturar.vicens.com

Certbot failed to authenticate some domains (authenticator: apache). The Certificate Authority reported these problems:
  Domain: facturar.vicens.com
  Type:   unauthorized
  Detail: 2a00:1d70:c01c::71:130: Invalid response from http://facturar.vicens.com/.well-known/acme-challenge/7_6iQ38ooAoQcjy5l8UwBY704eJpk3YguykPz9_OUng: "<br />\n<b>Fatal error</b>:  Uncaught Error: Call to undefined function mysql_error() in /furanet/sites/vicens.com/web/htdocs/wp-"

Hint: The Certificate Authority failed to verify the temporary Apache configuration changes made by Certbot. Ensure that the listed domains point to this Apache server and that it is accessible from the internet.

Some challenges have failed.
Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

My web server is (include version): Apache/2.4.38 (Debian)

The operating system my web server runs on is (include version): Debian 10

My hosting provider, if applicable, is: ionos

I can login to a root shell on my machine (yes or no, or I don't know): YES

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): NO

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

certbot 2.8.0

Welcome @nabil12

It looks like your IPv6 address points to a different server than your IPv4 address. Check that your DNS A and AAAA IP addresses match your respective public IP's. Use the https://letsdebug.net test site after making changes.

curl -i4 http://facturar.vicens.com
HTTP/1.1 302 Moved Temporarily
Server: Apache/2.4.38 (Debian)
Location: Login/

curl -i6 http://facturar.vicens.com
HTTP/1.1 200 OK
Server: Apache
<br />
<b>Fatal error</b>:  
Uncaught Error: Call to undefined function mysql_error() in /furanet/sites/vicens.com/web/htdocs/wp-content/plugins/revslider/inc_php/framework/db.class.php:29
2 Likes

It seems like they are on completely different ISPs too.

2 Likes

Using the online tool Let's Debug now yields these results https://letsdebug.net/facturar.vicens.com/1746243

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.