Problem with renew certificates - Cannot Import name account

Hi, we started to received this message below when you going to renew our certificates. We have already use branch 1.0 and 0.40.x, and both return this error. What could I do ?

My domain is:

I ran this command: /opt/letsencrypt/certbot-auto renew

It produced this output:
Traceback (most recent call last):
File “/opt/”, line 7, in
from certbot.main import main
File “/opt/letsencrypt/certbot/”, line 17, in
from certbot import account
ImportError: cannot import name account

My web server is (include version): NGINX

The operating system my web server runs on is (include version): Ubuntu 16.04

I can login to a root shell on my machine (yes or no, or I don’t know): yes

1 Like

Have you tried using either the official instructions for certbot-auto, or the official instructions for Ubuntu Xenial?

Running from git is not recommended .

If you choose to use certbot-auto, you may need to first remove /opt/ to ensure that the virtual environment is recreated correctly.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.