Problem with let's encrypt certificate and recaptcha


#1

Hey! (in advance sorry for the bad english) I had implemented recaptcha for forms in other servers with paid ssl and i got no problem. Now I’m implementing recaptcha in a domain with your ssl certificate and I always get error (I had created many versions to spot an error). The only conclusion I get is that it should be something wrong with the ssl. For applying the ssl to this domain I enable in the control panel from ipower because they have the defaul option and then making a .htaccess to redirect always to https.
Do you know if recaptcha is not compatible with let’s encrypt certificates? or Do you know something I could try?
Thank you for the time and help!!!

My domain is: https://www.afrumex.com/google_reCAPTCHA/prueba.html

I ran this command: submit

It produced this output: Please check the the captcha form2

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: ipower

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#2

I’m getting a green tick-mark on that testing captcha?

Do you have some kind of error message or a screenshot with the error of the captcha not working?


#3

Error when sending message

That means that the responce from recaptcha was success==false


#4

Hey! After struggling for a while trying to implement checkbox recaptcha v2 in my form, I tried to implement invisible recaptcha v2, and this one works perfectly. I don’t know how this can happen! You can see in function here

I don’t know if it has something to do with my ssl certificate (from let’s encrypt).

This tutorial help me a lot.

Thanks for the comments!


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.