Problem With le64.exe On Windows Server 2012R2

Hello Everyone,

I am using le64.exe on a Windows Server 2012 R2 to generate my SSL but the system has some issues.

le64.exe --key “C:\ssl\account.key” --csr “C:\ssl\mail.mydomain.mobi.csr” --csr-key “C:\ssl\mail.mydomain.mobi.key” --crt “C:\ssl\mail.mydomain.mobi.crt” --domains “mail.mydomain.mobi” --generate-missing --handle-as dns –live

2019/07/12 21:53:37 [ ZeroSSL Crypt::LE client v0.33 started. ]
Can’t locate utf8_heavy.pl in @INC (@INC contains: C:\Users\ADMINI~1.CIT\AppData
\Local\Temp\2\par-41646d696e6973747261746f72\cache-1553801689\inc\lib C:\Users\A
DMINI~1.CIT\AppData\Local\Temp\2\par-41646d696e6973747261746f72\cache-1553801689
\inc CODE(0x302a638) CODE(0x302a830)) at C:/Perl/Perl64/perl/lib/utf8.pm line 16
.

Kindly suggest.

I guess I found the issue. Syntax error;

wrong:
-live

correct:
–live (double dash)

Thanks everyone

1 Like

WS 2012 might have odd configurations, but usually there should be no issues there - the only similar case has been reported in 2017. Let me know if you see that issue again (via PM) - I know how this can be resolved and even though it seems to be an extremely rare case, I might account for that anyway.

Hey Man,

Thanks for response, as I mentioned earlier I saw there was (single -) not (double - -) before the live directive. Corrected that and everything worked since then.

Can you share the other solution you are talking about, this could help many of them if they got it.

Thanks

The other solution would be to rebuild the binaries with an additional option basically, so I think your observation regarding the parameters makes a better one :slight_smile: