Problem with certificate generated with certbot in vcenter

Hi there
I want to generate certificate using certbot for vcenter, for this reason I used this tutorial:

but when I provide cert.pem, privkey.pem and fullchain.pem, in continue vcenter says:
Command Output: /root/cert.pem: O = Digital Signature Trust Co., CN = DST Root CA X3
error 10 at 3 depth lookup:certificate has expired

What's the problem?
Does anyone know how can I generate certificate for vcenter?

@mike.smith I read that article you posted and the comments. The author said the process no longer works since the DST Root CA X3 root expired. In the recent comments he said he spent considerable time but never got it to work again. He linked to new instructions that worked using the ZeroSSL CA.

I mention this because the original article had many errors which were corrected in the comments section. It is difficult to put all the pieces together.

I am not familiar with VMware so cannot help trying to make it work. Someone else here may be able to see what went wrong in the article.

While waiting for someone, you could read more about the tradeoffs for the two chains that Lets Encrypt now offers. Perhaps you could show this article to the author and maybe he could see how to fix the instructions.


Hi @MikeMcQ. Thanks for your help. I used ZeroSSL CA and my problem is solved.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.