Problem running Certbot with apache

Is your hosting provider? If so ... I think your best bet might be to find an alternative.

  • You said your server is running apache, but the Server header says it's nginx.
  • You used the --standalone plugin. However, the server seems to be responding on port 443, which means the standalone plugin should have fail to listen on that port, which it apparently didn't - it thought it was listening and asked the CA to connect to it.
  • The certificate that's being presented is a wildcard cert for *

So it seems that your apache server is sitting behind an nginx reverse proxy controlled by the hosting provider. That means they must install any certificates for you.

Here is what they say about that ( redirects to so I assume they're the same company):

Let's Encrypt certificates need to be renewed at least every 3 months, so that's 40... I'm not sure what currency those prices are in, but there's a good chance it will work out more expensive than purchasing and installing a cheap multi-year certificate from a commercial CA. The arduous installation process is also an unfortunate barrier and will likely make it impossible to set up automated renewals.

Unsurprisingly, they also sell certificates themselves.

It may be that they have some other hosting options that are compatible with Let's Encrypt. I haven't seen anything about that on their website, though.

If you want to look for alternatives, the list of shared hosting providers that support Let's Encrypt is here:

(If ehosts is not your hosting provider, then my next best guess is that you mistyped your domain name...)

1 Like