Problem binding port 80 win error 1013

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: I first ran certbot renew and I was given the error Problem binding port 80 win error 1013. I know that I can be locked out when this happens so I have started running certbot certonly --standalone --dry-run

It produced this output:
Saving debug log to C:\Certbot\log\letsencrypt.log
Please enter the domain name(s) you would like on your certificate (comma and/or
space separated) (Enter 'c' to cancel):
Simulating a certificate request for

Certbot failed to authenticate some domains (authenticator: standalone). The Certificate Authority reported these problems:
Type: connection
Detail: Fetching Timeout during connect (likely firewall problem)

Hint: The Certificate Authority failed to download the challenge files from the temporary standalone webserver started by Certbot on port 80. Ensure that the listed domains point to this machine and that it can accept inbound connections from the internet.

Some challenges have failed. I noted that IIS was running. I have removed IIS and still the problem remains. I also used to easily run certbot renew but suddenly this is not working. AND I run this command: netstat -ano | find ":80" and I see that port 80 has 4 next to it as a PID. I wanted to run taskkill /PID 4 /f and I get this reply: ERROR: The process with PID 4 could not be terminated.
Reason: Access is denied. AND I have tried the above disabling the firewall as well. Same error. My certbot folder on the C:\ drive exists and I can see the certificates. AND the .well-known\acme-challenge\mytestfile.txt and certificate exist in the public folder of my web site.

My web server is (include version): A recent version of xampp for windows 10

The operating system my web server runs on is (include version): Up to date Windows 10

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): I serve the web site from my home server.

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): xampp

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): I today put in the latest version of certbot.

Hello @markjc, welcome to the Let's Encrypt community. :slightly_smiling_face:

Your Ports 80 and 443 are filtered; HTTP-01 challenge of the Challenge Types - Let's Encrypt requires Port 80. Best Practice - Keep Port 80 Open

$ nmap -Pn -p80,443
Starting Nmap 7.80 ( ) at 2023-05-02 16:17 UTC
Nmap scan report for (
Host is up.
rDNS record for

80/tcp  filtered http
443/tcp filtered https

Nmap done: 1 IP address (1 host up) scanned in 3.87 seconds

Testing and debugging are best done using the Staging Environment as the Rate Limits are much higher.

And to assist with debugging there is a great place to start is Let's Debug.

1 Like

Hi I am restoring my machine from a backup image. May I ask what you mean by ports filtered.
I will be looking at your reply and a solution tomorrow. X-hausted from a day trying to get this to work.

Kind regards. Mark.

No traffic is getting through to your web server for any number of reasons.

1 Like

Thank you.
May I keep this open. I will chase it again tomorrow after I have restored system image. Its driving me nuts. I used to be able to certbot renew easily. Now it's a struggle. I appreciate your help.

As I understand it I need to be able to open the .welcome/acme/text.text with xampp server on and using the browser. Then this will mean you can test to see if the filters are gone again?

What I am confused about is that I used to certbot renew with xampp off.

Anyway. Will go at it again tomorrow.

Keep well.



Yes! :slight_smile:

1 Like

Did you recently get a new router? Or, change some of its settings? Routers might have a firewall that is blocking ports.


Hi I did get a new router.
We have rolling blackouts and loadshedding in South Africa and it is chewing through our equipment.

BUT good news!

I am not sure how I did it but after an image re-install and configuring the router a little to add in port 80, and remembering to take off IIS from Windows added features, I seem somehow to have got my certificates renewed.

Thank you!

Mark Corrigan


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.