Privkey.pem has no (readable) content

Hi to all.

I tried to renew the certificate on my web server (MacOs 10.8.x)

I generated a new certificate, but when I try to import the privkey.pem (MacOS Server needs this!)
I get an error which says the privacy.pem has no content. This happens too when I try to import
it on my local iMac running the latest OS.

What can I do?

The recent certificate expires in 10 days :frowning:

Thanks,
Michael

The operating system my web server runs on is (include version):
MacOs 10.8.4

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):
Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
MacOs Server

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
certbot 0.35.1

1 Like

Hi @Seminar466

sounds like you don’t have enough rights.

Do you use sudo?

Sure.

And on MacOS it’s simply drag’n’drop.

Hi @Seminar466,

Welcome to the community forum!

Can you show us screenshots? OSX 10.8 is significantly out of date - the last update, 10.8.5, came out in 2013. Barring everything else, you should at least update to that patch level. https://support.apple.com/en-us/HT202785

Can you show us file information too?
ls -al *.pem

1 Like

Yes I know OSX 10.8 is old. But it’s a matter of money to buy a new Mac server at the moment.

But you helped me a lot!!!

Applying “ls -al *.pem” I saw that the private key - file had 0 bytes.
So I transferred a new one to the server, now it works.

(I have to use the certbot on my iMac here (10.14. :slight_smile: ))

So thanks a lot, never had the idea to check it.

Michael

3 Likes

Best of luck out there @Seminar466!

3 Likes