Please Help SSL keeps failing

Have you restarted Apache after that change? Because I don't see any change

2 Likes

ok restarted it now

We should check your public IP.

What does this show?

curl https://ifconfig.io
2 Likes

[root@vmi431722 ~]# curl https://ifconfig.io
5.189.166.189

And, what about the .htaccess file?

Does this show anything?

sudo find /etc/httpd -name .ht*
2 Likes

[root@vmi431722 ~]# sudo find /etc/httpd -name .ht
[root@vmi431722 ~]#

You would need to use .ht* to find it. Looks like you missed the asterisk

2 Likes

[root@vmi431722 ~]# sudo find /etc/httpd -name .ht*
[root@vmi431722 ~]#

I am running out of ideas. The Apache access log should be showing the test requests sent to your domain. But they do not show up. And, we also don't see the correct results from the changes we make to that VirtualHost (the change to the redirects).

You may need to seek help from your hosting provider (Contabo?). For some reason HTTP requests are not getting to your Apache.

We could look at these but I do not expect to see any problem

sudo ps -eF | grep -Ei "httpd|apache|:80"
sudo systemctl status --no-pager -l httpd
2 Likes
[root@vmi431722 ~]# sudo ps -eF | grep -Ei "httpd|apache|:80"
apache    1274  2800  0 65452 14372   5 14:47 ?        00:00:00 httpd
root      2800     1  0 64833 12360   2 Sep22 ?        00:02:23 httpd
apache    2805  2800  0 65053 10592   4 Sep22 ?        00:01:23 httpd
apache    3754  2800  0 64937 11740   5 17:12 ?        00:00:00 httpd
root      4454  1920  0 28203  1016   1 17:14 pts/0    00:00:00 grep --color=auto -Ei httpd|apache|:80
apache    6143  2800  0 65316 13908   5 15:14 ?        00:00:00 httpd
apache    8566  2800  0 65285 13740   1 15:28 ?        00:00:00 httpd
apache    8568  2800  0 65313 13780   5 15:28 ?        00:00:00 httpd
apache    8574  2800  0 65247 13436   5 15:28 ?        00:00:00 httpd
apache   27252  2800  0 65056 12904   5 16:44 ?        00:00:00 httpd
apache   27435  2800  0 65064 12648   5 16:46 ?        00:00:00 httpd
apache   29244  2800  0 65464 14544   5 14:20 ?        00:00:00 httpd
apache   29271  2800  0 65518 14804   5 14:20 ?        00:00:00 httpd
[root@vmi431722 ~]# 

AND

[root@vmi431722 ~]# sudo systemctl status --no-pager -l httpd
● httpd.service - The Apache HTTP Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
   Active: failed (Result: protocol) since Fri 2023-10-13 17:03:30 BST; 13min ago
     Docs: man:httpd(8)
           man:apachectl(8)
  Process: 1549 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=exited, status=0/SUCCESS)
 Main PID: 1549 (code=exited, status=0/SUCCESS)

Oct 13 17:03:30 vmi431722.contaboserver.net systemd[1]: Starting The Apache HTTP Server...
Oct 13 17:03:30 vmi431722.contaboserver.net httpd[1549]: AH00112: Warning: DocumentRoot [/home/priyaexc/public_html/mail] does not exist
Oct 13 17:03:30 vmi431722.contaboserver.net httpd[1549]: httpd (pid 2800) already running
Oct 13 17:03:30 vmi431722.contaboserver.net systemd[1]: Failed to start The Apache HTTP Server.
Oct 13 17:03:30 vmi431722.contaboserver.net systemd[1]: Unit httpd.service entered failed state.
Oct 13 17:03:30 vmi431722.contaboserver.net systemd[1]: httpd.service failed.
Oct 13 17:13:05 vmi431722.contaboserver.net systemd[1]: Unit httpd.service cannot be reloaded because it is inactive.
Oct 13 17:13:14 vmi431722.contaboserver.net systemd[1]: Unit httpd.service cannot be reloaded because it is inactive.
[root@vmi431722 ~]# 

1 Like

That is a big problem.

Looks like there are other VirtualHosts in that Apache setup (the missing DocumentRoot). And, something is causing it to fail to start. This means an older Apache is still running.

You should contact your hosting provider for assistance. Or, perhaps a VirtualMin or Apache support forum. While we often help with common mis-configurations of web servers we are not a general purpose Apache support forum.

Once you get a properly working Apache try again and let us know if any problems.

2 Likes

OK will try that thanks for all your patience and help so far with this Miks

One last question

I wonder if I backed up the website - then deleted the virtualmin hosting of this site and then created a new fresh hosting and restored the website - you think that may help?
should I bother to try that?

1 Like

It is hard for me to say. There is too much info missing.

Do you even know why the warning message about this folder is issued?

1 Like

I think it may be as I have no SSL for mail
I have many websites hosted and allowed emails a long time ago - I stopped all emails from the servers since and so the automated SSL may occasionally be trying to get the .webmail
maybe that's why
I have no emails coming in or out of the servers since about 3 years ago

should just go and delete this? I've not seen it before so didn't know it was there

Sorry, I have reached my Apache support limit for the day :slight_smile:

Like most of the helpers here, I offer my time and expertise for free. There's only so much I wish to do, or even can do, when there is such fundamental config problems.

2 Likes

Thank you so so much for your patience and help so far - I have learnt a lot during this as well, I'll try the Apache forum and see if I can get this sorted - Thanks again Mike :+1:

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.