Pagespeed not supported?


#1

I’m using latest Ubuntu, fully up-to-date, with Apache 2.4.17 supporting https2. I’ve also pagespeed.

So when running letsencrypt, I got the following error:

root@ns1:/tmp/letsencrypt# ./letsencrypt-auto --apache
Updating letsencrypt and virtual environment dependencies…
Running with virtualenv: /root/.local/share/letsencrypt/bin/letsencrypt --apache
The apache plugin is not working; there may be problems with your existing configuration.
The error was: PluginError((‘There has been an error in parsing the file (%s): %s’, u’/etc/apache2/mods-enabled/pagespeed.conf’, u’Syntax error’),)

So I guess there is some inconsistency ?


#2

jest, it sounds as if there is an inconsistency, so it’s down to a little debugging :wink: It may well be worth disabling the pagespeed and testing to see if you can get a cert - which will then confirm that’s where the inconsistency is.