"Not Secure" - MediaWiki site hosted on Vultr

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: intsdigital.net

I ran this command:

It produced this output:

My web server is (include version): Nginx 1.16.1

The operating system my web server runs on is (include version): Ubuntu 18.04.3 LTS (Bionic)

My hosting provider, if applicable, is: Vultr

I can login to a root shell on my machine (yes or no, or I don’t know): I don’t know.

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): I don’t know?

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.13.0

Hi, I’m very, very new to hosting my own MediaWiki site, php, and hosting via a cloud provider. I can’t seem to get my SSL up and running, as my domain still redirects to my IP. I use the console through Vultr. The nameservers are correct and the propagation (last I checked) is mostly done, but I’m still receiving the “not secure” warning when I go to my homepage. Is this a propagation issue or something else? I had no issues following Let’s Encrypt’s documentation. Any advice is appreciated.

Hi @lmacdon5

checking your domain that's

the problem - https://check-your-website.server-daten.de/?q=intsdigital.net

Domainname Http-Status redirect Sec. G
http://intsdigital.net/ 301 https://intsdigital.net/ Html is minified: 109,03 % 0.217 A
http://www.intsdigital.net/ 301 https://www.intsdigital.net/
Html is minified: 109,03 % 0.220 A
https://intsdigital.net/ 301 3.937 B
https://www.intsdigital.net/ 301 5.653 N
Certificate error: RemoteCertificateNameMismatch, RemoteCertificateChainErrors No GZip used - 5243 / 13931 - 37,64 % possible Inline-JavaScript (∑/total): 3/2445 Inline-CSS (∑/total): 0/0 200 Html is minified: 140,60 % 2.720 N
Certificate error: RemoteCertificateNameMismatch, RemoteCertificateChainErrors

Your certificate doesn't work with your ip address. How do you manage that website? There is somewhere that redirect you have to remove.

I manage everything through the Vultr console for my site. Is there a series of commands for removing the redirect?


It seems like you’ll need to edit the site settings and change the site host from your IP to domain

Thank you

Thanks for the suggestions. I’m afraid this just too over my head. Going to make do without an SSL.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.