Non-interactvie does not work for some reason

My domain is: mattermost.huhololand.cz

I ran this command: certbot --nginx --non-interactive --agree-tos -m mattermost@huhololand.cz -d mattermost.huhololand.cz -d www.mattermost.huhololand.cz

It produced this output:
It asks for PEM pass phrase and does not provide any clue what is missing to run in non interactive mode

My web server is (include version): nginx 1.17.10

The operating system my web server runs on is (include version): ubuntu 20.04

My hosting provider, if applicable, is: vps on vpsfree.cz

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.40.0

When I add --non-interactive flag, it still asks for pem pass phrase and it does not say what is missing to run in non interactive mode (as documentation sais).

looking forward for any advice!

Cheers,
Tobiáš

1 Like

I’m not sure how Certbot would be capable of asking for a passphrase.

Are you using hooks?

Could you share the full /var/log/letsencrypt/letsencrypt.log from a non-interactive run?

1 Like

If you have obtained certs for either of those names before, that previous config may be causing a problem now.
Please also show any relevant renewal conf files.

2 Likes

Hello,
that was it. I had specified certificate, i totaly forgot about that yesterday… :smiley:

Also as _az said, there was a hint in log. I did take a look there yesterday but I missed it.

Thanks a lot, it looks like it works just fine now.

1 Like