No Live Directory/No Certs


#1

I’m missing something I ran the commands below - and I received two errors for domains I shouldn’t have included in the list. I tested and it didn’t work and I reran and hit limits.

when I check /etc/letsencrypt I find only these directories:

drwx------ 3 root root 4096 Apr 19 09:04 accounts
drwxr-xr-x 2 root root 4096 Apr 19 09:45 csr
drwx------ 2 root root 4096 Apr 19 09:45 keys
-rw-r–r-- 1 root root 1591 Apr 19 09:04 options-ssl-apache.conf
drwxr-xr-x 2 root root 4096 Apr 19 09:22 renewal
drwxr-xr-x 5 root root 4096 Apr 19 09:04 renewal-hooks

Can’t figure out what next steps could/would/should be?

My domain is: Multiple www.universal-promotions.com is one of them

I ran this command:
sudo yum install certbot-apache
sudo certbot --apache

It produced this output: I ran it too many times and limited out

My web server is (include version): Apache

The operating system my web server runs on is (include version): CentOS Linux release 7.2.1511

My hosting provider, if applicable, is:Linode

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No


#2

Hi,

This means you hit the rate limit (failed certificates per hour)
If you urgently need a certificate, please add another host name on it (just to bypass the rate limit)

Also, please check your proper cronjob or what to avoid issuing duplicate certificates or failed to issue (since it might cause trouble to future renew)

Thank you

P.S. you can test the validation by adding--staging (kind of amazed that my keyboard remembered this)

updated according to @schoen


#3

@stevenzhu, there are no certificates at all for this domain on crt.sh and there’s no /etc/letsencrypt/archive so I think the certificates were never issued at all. In that case the rate limit is the failed authorization rate limit (which applies to failed attempts, not issuances) and that will expire in just 1 hour.

I wish all forum posters would please post the exact error message that they get, not just the fact that there was an error. There are probably over 30 different reasons that certificate issuance can fail and something like 5 different rate limits. So we won’t know what went wrong unless we can see the specific error.


#4

Thanks - that was enough of a clue that I could get it to work.


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.