New HTTPS activation failed

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: certbot --apache

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
Enter email address (used for urgent renewal and security notices) (Enter ‘c’ to

Please read the Terms of Service at You must
agree in order to register with the ACME server at

(A)gree/©ancel: a

Would you be willing to share your email address with the Electronic Frontier
Foundation, a founding partner of the Let’s Encrypt project and the non-profit
organization that develops Certbot? We’d like to send you email about our work
encrypting the web, EFF news, campaigns, and ways to support digital freedom.

(Y)es/(N)o: n

Which names would you like to activate HTTPS for?


Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter ‘c’ to cancel):
Obtaining a new certificate
An unexpected error occurred:
Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/urllib3/”, line 387, in _make_request
six.raise_from(e, None)
File “”, line 3, in raise_from
File “/usr/lib/python3/dist-packages/urllib3/”, line 383, in _make_request
httplib_response = conn.getresponse()
File “/usr/lib/python3.6/http/”, line 1346, in getresponse
File “/usr/lib/python3.6/http/”, line 307, in begin
version, status, reason = self._read_status()
File “/usr/lib/python3.6/http/”, line 268, in _read_status
line = str(self.fp.readline(_MAXLINE + 1), “iso-8859-1”)
File “/usr/lib/python3.6/”, line 586, in readinto
return self._sock.recv_into(b)
File “/usr/lib/python3.6/”, line 1012, in recv_into
return, buffer)
File “/usr/lib/python3.6/”, line 874, in read
return, buffer)
File “/usr/lib/python3.6/”, line 631, in read
v =, buffer)
socket.timeout: The read operation timed out

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/requests/”, line 440, in send
File “/usr/lib/python3/dist-packages/urllib3/”, line 639, in urlopen
File “/usr/lib/python3/dist-packages/urllib3/util/”, line 367, in increment
raise six.reraise(type(error), error, _stacktrace)
File “/usr/lib/python3/dist-packages/”, line 693, in reraise
raise value
File “/usr/lib/python3/dist-packages/urllib3/”, line 601, in urlopen
File “/usr/lib/python3/dist-packages/urllib3/”, line 389, in _make_request
self._raise_timeout(err=e, url=url, timeout_value=read_timeout)
File “/usr/lib/python3/dist-packages/urllib3/”, line 309, in _raise_timeout
raise ReadTimeoutError(self, url, “Read timed out. (read timeout=%s)” % timeout_value)
urllib3.exceptions.ReadTimeoutError: HTTPSConnectionPool(host=‘’, port=443): Read timed out. (read timeout=45)

During handling of the above exception, another exception occurred:

requests.exceptions.ReadTimeout: HTTPSConnectionPool(host=‘’, port=443): Read timed out. (read timeout=45)
Please see the logfiles in /var/log/letsencrypt for more details.


  • Your account credentials have been saved in your Certbot
    configuration directory at /etc/letsencrypt. You should make a
    secure backup of this folder now. This configuration directory will
    also contain certificates and private keys obtained by Certbot so
    making regular backups of this folder is ideal.

My web server is (include version): Apache/2.4.29 (Ubuntu)

The operating system my web server runs on is (include version): Ubuntu 18.04 (LTS)

My hosting provider, if applicable, is: linode VPS

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.31.0

Hi @walpi

are you sure your server is able to connect Letsencrypt?

What says



Boulder: The Let's Encrypt CA

  <div class="col-xs-6 text-left">
    <small>The Let's Encrypt CA</small></h1>

<div class="row">
  <div class="col-xs-8 col-xs-offset-2 text-center">
    <h3>This is an <a href="">ACME</a> Certificate Authority running <a href="">Boulder</a>.</h3>
    <p>This is a <em>programmatic</em> endpoint, an API for a computer to talk to. You should probably be using a specialized client to utilize the service, and not your web browser. See <a href=""><tt></tt></a> for help.</p>
    <p>If you're trying to use this service, note that the starting point, <em>the directory</em>, is available at this URL: <a href=""><tt></a></tt>.</p>
<div class="row">
  <div class="col-xs-4 col-xs-offset-2 text-center">
    <p><a href="" title="Twitter">
      <i class="fa fa-area-chart"></i>
      Service Status (
  <div class="col-xs-4 text-center">
    <p><a href="" title="Twitter">
      <i class="fa fa-twitter"></i>
      Check with us on Twitter
</div> <!-- row -->
root@web:/var/www/html/ # traceroute traceroute to (, 30 hops max, 60 byte packets 1 ( 0.913 ms ( 0.892 ms ( 0.896 ms 2 ( 0.883 ms 0.878 ms ( 0.714 ms 3 ( 1.879 ms ( 2.453 ms ( 2.436 ms 4 * * * 5 * * * 6 * * * 7 * * * 8 * * * 9 * * * 10 * * * 11 * * * 12 * * * 13 * * * 14 * * * 15 * * * 16 * * * 17 * * * 18 * * * 19 * * * 20 * * * 21 * * * 22 * * * 23 * * * 24 * * * 25 * * * 26 * * * 27 * * * 28 * * * 29 * * * 30 * * * root@web:/var/www/html/

Same thing here, timeout to acme-v02 while trying to renew Nextcloud cert. Service shows green status, but appears to be unreachable.

curl works, so you can talk to the server.

Your traceroute doesn’t work. My tracert works.

Works it with ipv6? (perhaps -6)

There were some cdn - changes.

Perhaps reduce your MTU.

I’m now getting this:
SSLError: HTTPSConnectionPool(host=‘’, port=443): Max retries exceeded with url: /directory (Caused by SSLError(SSLError(“bad handshake: SysCallError(104, ‘ECONNRESET’)”,),))

I was only getting as far as Level 3 on, but whatever the problem was with the next hop it is now resolved, my cert is updated.

Mine worked now too.

Curious. Thanks for reporting back :+1:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.