New certificate not used after letsencrypt renew


#1

I have a cert due to expire on the 15th.

I ran the letsencrypt-auto renew command. One of my domain got renewed. but then in browser expiration still shows April 15th.

So I rerun the command letsencrypt-auto certonly and I have:

./letsencrypt-auto certonly -a webroot -w /var/www/domain.tld/web -d www.domain.tld
Checking for new version…
Requesting root privileges to run letsencrypt…
/root/.local/share/letsencrypt/bin/letsencrypt certonly -a webroot -w /var/wwwdomain.tld/web -d www.domain.tld

You have an existing certificate that contains exactly the same domains you requested and isn’t close to expiry.
(ref: /etc/letsencrypt/renewal/www.domain.tld.conf)

What would you like to do?

1: Keep the existing certificate for now
2: Renew & replace the cert (limit ~5 per 7 days)

I tried option 2 but still… Cert is due to expire on 15th. So I don’t understand…


Help us test renewal with "letsencrypt renew"
#2

certonly won’t reload your web server for you. Most server software needs a reload in order to start using the new certificate.


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.