Net::err_cert_common_name_invalid

My domain is: bomdia.de

My problem: I tried to get to the website after using the letsencrypt certificate for the first time. I got an error from the browser at first, that my website is not secure and the certificate invalid. After activating hsts and adding DKIM and www as CNAME to the dns settings, it worked for a few hours. After that I didn't change anything but now it is again not working anymore.
I am really new and inexperienced with webside creation and hosting! I might have made an obvious mistake.

It produced this output: NET::ERR_CERT_COMMON_NAME_INVALID

My hosting provider, if applicable, is: kasserver

Here is my SSL Report: SSL Server Test: bomdia.de (Powered by Qualys SSL Labs)

bomdia.de and www.bomdia.de are two different domain names as far as certificates are concerned.

You should get a certificate that's valid for both.

3 Likes

How do I get this for www.bomdia.de?

Did you use certbot?

When it asks for a domain name, you give both bomdia.de and www.bomdia.de

5 Likes