Need help upgrading certbot client on Ubuntu 14

I’m trying to upgrade certbot on my Ubuntu 14 server. I understand that Ubuntu 14’s EOL has passed, but I’d like to upgrade certbot before I upgrade Ubuntu to meet the certbot v1 EOL June deadline.

My current certbot version is 0.19.0. I found that when running sudo apt-get update it does not see a new version for certbot. When running sudo apt install --only-upgrade certbot it says 0 packages were installed since apt-get update did not see a new version.

Is there any way to force download a new version onto Ubuntu 14?

I do not understand why my OS will not install a new version of certbot :frowning:

Additionally, I noticed one person solved this same problem but did not leave any steps for others to upgrade:

Hi @coffee22

why do you think your expired OS should be able to install a too new program?

That’s the wrong order. Update your OS, then you can install a newer Certbot.

Create new certificates, then you have 90 days to update your OS.

tyvm for your reply @JuergenAuer . I assumed I would need to upgrade the OS first, but after reading the reply in How to update to ACME v2 with old certbot installation I figured I could skirt this somehow.

I guess I’ll go back to step 1 to the OS. Thanks again

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.