My website crash too many redirect after instaling let's encrypt

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: guesthost.tech

I ran this command: sudo journalctl -u apache2.service --since today --no-pager

It produced this output:
-- Logs begin at Sat 2021-05-29 23:32:48 UTC, end at Wed 2021-06-02 12:07:51 UTC. --
Jun 02 00:00:18 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 systemd[1]: Reloading The Apache HTTP Server.
Jun 02 00:00:18 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 apachectl[46306]: AH00526: Syntax error on line 20 of /etc/apache2/sites-enabled/000-default-le-ssl.conf:
Jun 02 00:00:18 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 apachectl[46306]: SSLCertificateFile: file '/etc/letsencrypt/live/guesthost.tech/fullchain.pem' does not exist or is empty
Jun 02 00:00:18 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 apachectl[46303]: Action 'graceful' failed.
Jun 02 00:00:18 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 apachectl[46303]: The Apache error log may have more information.
Jun 02 00:00:18 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 systemd[1]: apache2.service: Control process exited, code=exited, status=1/FAILURE
Jun 02 00:00:18 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 systemd[1]: Reload failed for The Apache HTTP Server.
Jun 02 11:20:38 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 systemd[1]: Stopping The Apache HTTP Server...
Jun 02 11:20:38 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 apachectl[51822]: AH00526: Syntax error on line 20 of /etc/apache2/sites-enabled/000-default-le-ssl.conf:
Jun 02 11:20:38 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 apachectl[51822]: SSLCertificateFile: file '/etc/letsencrypt/live/guesthost.tech/fullchain.pem' does not exist or is empty
Jun 02 11:20:38 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 apachectl[51820]: Action 'graceful-stop' failed.
Jun 02 11:20:38 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 apachectl[51820]: The Apache error log may have more information.
Jun 02 11:20:38 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 systemd[1]: apache2.service: Control process exited, code=exited, status=1/FAILURE
Jun 02 11:20:39 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 systemd[1]: apache2.service: Failed with result 'exit-code'.
Jun 02 11:20:39 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 systemd[1]: Stopped The Apache HTTP Server.
Jun 02 11:20:39 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 systemd[1]: Starting The Apache HTTP Server...
Jun 02 11:20:39 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 apachectl[51837]: AH00526: Syntax error on line 20 of /etc/apache2/sites-enabled/000-default-le-ssl.conf:
Jun 02 11:20:39 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 apachectl[51837]: SSLCertificateFile: file '/etc/letsencrypt/live/guesthost.tech/fullchain.pem' does not exist or is empty
Jun 02 11:20:39 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 apachectl[51825]: Action 'start' failed.
Jun 02 11:20:39 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 apachectl[51825]: The Apache error log may have more information.
Jun 02 11:20:39 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 systemd[1]: apache2.service: Control process exited, code=exited, status=1/FAILURE
Jun 02 11:20:39 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 systemd[1]: apache2.service: Failed with result 'exit-code'.
Jun 02 11:20:39 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 systemd[1]: Failed to start The Apache HTTP Server.
Jun 02 11:34:50 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 systemd[1]: Starting The Apache HTTP Server...
Jun 02 11:34:50 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 apachectl[51904]: AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
Jun 02 11:34:51 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 systemd[1]: Started The Apache HTTP Server.
Jun 02 11:49:50 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 systemd[1]: Stopping The Apache HTTP Server...
Jun 02 11:49:50 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 apachectl[52267]: AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
Jun 02 11:49:50 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 systemd[1]: apache2.service: Succeeded.
Jun 02 11:49:50 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 systemd[1]: Stopped The Apache HTTP Server.
Jun 02 11:49:50 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 systemd[1]: Starting The Apache HTTP Server...
Jun 02 11:49:50 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 apachectl[52283]: AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
Jun 02 11:49:50 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 systemd[1]: Started The Apache HTTP Server.
Jun 02 11:58:36 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 systemd[1]: Reloading The Apache HTTP Server.
Jun 02 11:58:36 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 apachectl[52618]: AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
Jun 02 11:58:36 wordpress-ubuntu-s-1vcpu-1gb-nyc3-01 systemd[1]: Reloaded The Apache HTTP Server.

My web server is (include version):Ubuntu 20.04.2 LTS (GNU/Linux 5.4.0-73-generic x86_64)

The operating system my web server runs on is (include version):GNU/Linux 5.4.0-73-generic x86_64

My hosting provider, if applicable, is: digital ocean

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):no digital ocean

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

hey
I tied to connect a Facebook app with my website but Facebook told me that my connection is not secure so I tried to install let's encrypt SSL.
I have to let you know that my website was running in HTTPS I don't know if that because of an existing SSL already installed with WordPress or because my website is connected to Cloudflare.
I ignored this and installed let's encrypt SSL with the command certbot -- apache .
after that, an error occurred on my website. TO MANY REDIRECT
I tried clearing cookies and cache. I followed many tutorials but in vain.
i tried to delete SSL and ssl files with this command
sudo a2dismod SSL
sudo a2dissite default-SSL
sudo service apache2 restart
I deleted all SSL files and my website is always down.
I'm completely newbie and need detailed instructions for help
please it's urgent

1 Like

First step is to restore the SSL files from the backup you've made of them.

1 Like

I don't think I have made a backup

You should delete /etc/apache2/sites-enabled/000-default-le-ssl.conf and then Apache should be able to start again.

1 Like

hey sorry! i'm late responding I did what you said and I think I was able to restart apache but my website is always down ERR_TOO_MANY_REDIRECTS if you can help me solve this problem
I already explained above what I did that makes my website down

1 Like

Welcome to the Let's Encrypt Community, Ayoub :slightly_smiling_face:

Please make sure that the Site Address (URL) and WordPress Address (URL) settings in WordPress both begin with https:

Also...

Please make sure your Cloudflare SSL option is set to Full and not Full (strict).

You should look into using Cloudflare Origin CA certificates instead of Let's Encrypt certificates. They last much longer and are easier to manage when using Cloudflare.

https://developers.cloudflare.com/ssl/origin-configuration/origin-ca

1 Like

hey, griffin thank you for your reply,
I checked my cloud flair SSL and set it to full.
I restarted the droplet and know I have the error 521 your server is down.
I checked the log error file and here is what I find

[Wed Jun 09 00:00:22.431500 2021] [http2:warn] [pid 52285] AH10034: The mpm module (prefork.c) is not supported by mod_http2. The mpm determines how things are processed in your server. HTTP/2 has more demands in this regard and the currently selected mpm will just not do. This is an advisory warning. Your server will continue to work, but the HTTP/2 protocol will be inactive.
[Wed Jun 09 00:00:22.431545 2021] [http2:warn] [pid 52285] AH02951: mod_ssl does not seem to be enabled
[Wed Jun 09 00:00:22.604374 2021] [mpm_prefork:notice] [pid 52285] AH00163: Apache/2.4.46 (Ubuntu) configured -- resuming normal operations
[Wed Jun 09 00:00:22.604408 2021] [core:notice] [pid 52285] AH00094: Command line: '/usr/sbin/apache2'
[Wed Jun 09 21:49:39.914951 2021] [mpm_prefork:notice] [pid 52285] AH00170: caught SIGWINCH, shutting down gracefully
[Wed Jun 09 21:49:40.178873 2021] [http2:warn] [pid 122109] AH10034: The mpm module (prefork.c) is not supported by mod_http2. The mpm determines how things are processed in your server. HTTP/2 has more demands in this regard and the currently selected mpm will just not do. This is an advisory warning. Your server will continue to work, but the HTTP/2 protocol will be inactive.
[Wed Jun 09 21:49:40.178919 2021] [http2:warn] [pid 122109] AH02951: mod_ssl does not seem to be enabled
[Wed Jun 09 21:49:40.234641 2021] [mpm_prefork:notice] [pid 122109] AH00163: Apache/2.4.46 (Ubuntu) configured -- resuming normal operations
[Wed Jun 09 21:49:40.234684 2021] [core:notice] [pid 122109] AH00094: Command line: '/usr/sbin/apache2'
[Wed Jun 09 21:55:34.717338 2021] [mpm_prefork:notice] [pid 122109] AH00170: caught SIGWINCH, shutting down gracefully
[Wed Jun 09 21:55:34.926527 2021] [http2:warn] [pid 122184] AH10034: The mpm module (prefork.c) is not supported by mod_http2. The mpm determines how things are processed in your server. HTTP/2 has more demands in this regard and the currently selected mpm will just not do. This is an advisory warning. Your server will continue to work, but the HTTP/2 protocol will be inactive.
[Wed Jun 09 21:55:34.926614 2021] [http2:warn] [pid 122184] AH02951: mod_ssl does not seem to be enabled
[Wed Jun 09 21:55:35.006263 2021] [mpm_prefork:notice] [pid 122184] AH00163: Apache/2.4.46 (Ubuntu) configured -- resuming normal operations
[Wed Jun 09 21:55:35.006385 2021] [core:notice] [pid 122184] AH00094: Command line: '/usr/sbin/apache2'
[Wed Jun 09 21:55:46.900107 2021] [mpm_prefork:notice] [pid 122184] AH00171: Graceful restart requested, doing restart
[Wed Jun 09 21:55:46.980400 2021] [http2:warn] [pid 122184] AH10034: The mpm module (prefork.c) is not supported by mod_http2. The mpm determines how things are processed in your server. HTTP/2 has more demands in this regard and the currently selected mpm will just not do. This is an advisory warning. Your server will continue to work, but the HTTP/2 protocol will be inactive.
[Wed Jun 09 21:55:46.980425 2021] [http2:warn] [pid 122184] AH02951: mod_ssl does not seem to be enabled
[Wed Jun 09 21:55:47.010878 2021] [mpm_prefork:notice] [pid 122184] AH00163: Apache/2.4.46 (Ubuntu) configured -- resuming normal operations
[Wed Jun 09 21:55:47.010917 2021] [core:notice] [pid 122184] AH00094: Command line: '/usr/sbin/apache2'
[Wed Jun 09 23:51:45.028536 2021] [mpm_prefork:notice] [pid 122184] AH00170: caught SIGWINCH, shutting down gracefully
[Wed Jun 09 23:52:04.555713 2021] [http2:warn] [pid 833] AH10034: The mpm module (prefork.c) is not supported by mod_http2. The mpm determines how things are processed in your server. HTTP/2 has more demands in this regard and the currently selected mpm will just not do. This is an advisory warning. Your server will continue to work, but the HTTP/2 protocol will be inactive.
[Wed Jun 09 23:52:04.568492 2021] [http2:warn] [pid 833] AH02951: mod_ssl does not seem to be enabled
[Wed Jun 09 23:52:05.485295 2021] [mpm_prefork:notice] [pid 833] AH00163: Apache/2.4.46 (Ubuntu) configured -- resuming normal operations
[Wed Jun 09 23:52:05.485364 2021] [core:notice] [pid 833] AH00094: Command line: '/usr/sbin/apache2'

the first steps changing the site Url I can't do it because I can't access my WordPress admin.
I will try to install Cloudflare SSL and see the changes.
If you can help me I will appreciate it

2 Likes

Have you tried @schoen's suggestion above?

My website crash too many redirect after instaling let's encrypt - #4 by schoen

1 Like

yes the apache restarts but my website still in crash =(

2 Likes

Did you try acquiring and installing a Cloudflare Origin CA certificate? You might need to set the Cloudflare SSL option to Off until you can get your webserver operating correctly.

http://guesthost.tech
301 Moved Permanently
https://guesthost.tech/
521 Origin Down

https://www.redirect-checker.org/

1 Like

I have deactivated Cloudflare SSL but the website still down. I must have my website run before installing Cloudflare SSL?

2 Likes

Now Cloudflare is showing the circular redirect. You should be able to login to your WordPress admin now to fix the 2 settings I mentioned before.

http://guesthost.tech/
301 Moved Permanently
https://guesthost.tech/
301 Moved Permanently
http://guesthost.tech/
...

1 Like

I tried http://guesthost.tech/wp-admin/ but still get the same error

2 Likes

i tried also https://guesthost.tech/wp-admin/ but it leads to http://guesthost.tech

2 Likes

I see that. Let's try setting the Cloudflare SSL option to Flexible. Let me know once that's done.

1 Like

I changed the SSL to FLexible

2 Likes

Same result, as expected.

What webserver software (e.g. apache, nginx, IIS) are you using on your webserver?

1 Like

appache web server digital ocean

2 Likes

Can you SSH into your webserver?

1 Like

you mean can i log to my webserver ? yes i use putty or the console

2 Likes