My certificate is expired and now site is showing 526 error


#1

Hello all my letsencrypt certificate expired today. Now my website is losing visitors. I am trying to renew certificate but its showing some errors.
My website is also using cloudflare.

My domain: https://eduboardresults.in

My vps provider is: Linode

Also Using Cloudflare CDN.

OS: Ubuntu 14

I ran this command:
./certbot-auto renew

i got this output:

root@localhost:/opt/letsencrypt# ./certbot-auto renew
Saving debug log to /var/log/letsencrypt/letsencrypt.log


Processing /etc/letsencrypt/renewal/eduboardresults.in.conf

Cert is due for renewal, auto-renewing…
Plugins selected: Authenticator webroot, Installer None
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for eduboardresults.in
http-01 challenge for www.eduboardresults.in
Waiting for verification…
Cleaning up challenges
Attempting to renew cert (eduboardresults.in) from /etc/letsencrypt/renewal/eduboardresults.in.conf produced an unexpected error: Failed authorization procedure. eduboardresults.in (http-01): urn:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://eduboardresults.in/.well-known/acme-challenge/DrPAn75f2sIN7Ftn_NmKpwZzsEDuKqK6h-wQHcWvqNU: "

<html class="no-js " To fix these errors, please make sure that your domain name was entered correctly and the DNS A/AAAA record(s) for that domain contain(s) the right IP address. Please Help Me . I am losing visitors.

#2

If you use Cloudflare and Cloudflare is blocking access to your site due to an invalid certificate, you cannot use http-01 authorization.

I would just disable Cloudflare while issuing another certificate.


#3

so what can i do now brother


#4

As @bytecamp said, you can disable Cloudflare while you try to renew. As an alternative, you can just install the free origin cert that Cloudflare gives you.


#5

The first thing you should do is configure cloudflare to use Flexible SSL instead of Full SSL to bring back your site.


#6

ok changed to flexible … now ?


#7

Are you sure it is changed?


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.