Multiple wildcards under the same domain don't generate correctly

My domain is: *, *

I ran this command:

sudo certbot certonly --manual -d *
sudo certbot certonly --manual -d *

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator manual, Installer None
Obtaining a new certificate

 - Congratulations! Your certificate and chain have been saved at:
   Your key file has been saved at:
   Your cert will expire on 2020-08-26. To obtain a new or tweaked
   version of this certificate in the future, simply run certbot
   again. To non-interactively renew *all* of your certificates, run
   "certbot renew"
 - If you like Certbot, please consider supporting our work by:

   Donating to ISRG / Let's Encrypt:
   Donating to EFF:          

My web server is (include version): nginx version: nginx/1.14.0 (Ubuntu)

The operating system my web server runs on is (include version): Ubuntu 18.04.2 LTS

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.31.0

So I have two wildcard domains hosted on different servers
If you visit for example, you’ll see that it’s getting the s3-staging cert.
Which should be impossible because I never generated a s3-staging cert on that host.

So to be more succinct the problem that I’m having is that when I run sudo certbot certonly --manual -d * I get a s3-staging certificate

What could I be doing wrong here?

1 Like

So the problem was that I had two A records pointing to both hosts. :woman_facepalming:

Disregard this post please

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.