Messed up with renewal


#1

Hello, I am testing certbot on my proxy-server using nginx and the first installation worked fine. Now I tried the renewal using:
$ sudo certbot renew --dry-run
Now nginx does not start anymore. I removed and re-installed all but I get the same error as after renewal:

The nginx plugin is not working; there may be problems with your existing configuration.
The error was: MisconfigurationError(‘Error while running nginx -c /etc/nginx/nginx.conf -t.\n\nnginx: [warn] low address bits of 10.0.7.0/16 are meaningless in /etc/nginx/sites-enabled/default:320\nnginx: [emerg] BIO_new_file("/etc/letsencrypt/live/proxyserver.com/fullchain.pem") failed (SSL: error:02001002:system library:fopen:No such file or directory:fopen(’/etc/letsencrypt/live/geoservice2.ist.supsi.ch/fullchain.pem’,‘r’) error:2006D080:BIO routines:BIO_new_file:no such file)\nnginx: configuration file /etc/nginx/nginx.conf test failed\n’,)

Removing all does not change the nginx configuration file I think. In fact no certificates appear.
Now I am really stuck (as a newby).
Any idea what to do now?


#2

so the problem is that I do not have the /etc/letsencrypt/live/proxyserver.com/fullchain.pem key anymore (stupid me, I removed /etc/letsencrypt directorry). I cannot get it back using $ sudo certbot --nginx.

Thanks for your help


#3

I made it,
got a new certificate and placed the files in the right place…

Best


closed #4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.