Manual install doesn't allow apache2 to read certs

I was able to successfully generate a key and cert for my domain, and I can read them via sudo in the cli. Copying the location (again, that is accessible manually when I do sudo vim {location}) and putting into my apache2 config for the certificate private key location and restarting my server (configtest returns OK), results in this:

AH02241: Init: Unable to read server certificate from file /etc/letsencrypt/live/

The confusing thing is that the permissions on the actual files are 0755.

Apache2 runs as www-data, which is not part of the root group, but with those permissions, it shouldn’t need to be.

I’m at a loss of what to keep checking. Has anyone else had this issue?


Required stuff:

Please fill out the fields below so we can help you better.

My domain is:

I ran this command: sudo certbot certonly --manual -d

It produced this output: (everything worked, I can see the certs)

My web server is (include version): Apache/2.4.7

The operating system my web server runs on is (include version): Ubuntu 14.04

My hosting provider, if applicable, is: AWS EC2

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

It looks like you have the private key file listed as the certificate file. Double-check your configuration.

SSLCertificateFile should contain cert.pem.
SSLCertificateKeyFile should contain privkey.pem.
SSLCertificateChainFile should contain chain.pem.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.