Mac support requires insecure binaries be installed


I can’t use this software because I don’t want to install homebrew on my mac…
homebrew wants to download binaries from untrusted sources and install these on my computer.

by comparison if I were running Linux instead of OS X, those binaries would come from the distro maker. in the case of homebrew, they are coming from some random server maintained by some random person and that is a large security risk.

to the developers of let’s encrypt I shall ask the question:
Why can’t you folks produce a more portable program?



  1. i also asked me the question…
  2. The protocol is open and with some questions it is possible to code it in java with about 1200 lines of code.
    Than you have no requirements except plain sun jdk


Would a PHP standalone client help you? I could modify my library to include a binary for that.


Yes if it’s source code.
what do you mean by binary in this context?


Just some bin/acme script that’s executable.


Why not provide source I can examine?


Of course as source, not a real binary… just an executable file.


OK cool that sounds like it would help people e.g. myself


List of Client Implementations has a bunch of other options than the reference client. There are some really simple options and even a website that provides manual commands you can run yourself without anything on your own system other than OpenSSL.