LetsEncrypt with Virtualmin got "SuExec is not enabled" error


#1

When I realized letsencrypt is an option in Virtualmin, I tried installing it that way using these instructions:

But it halted on this error:

Validating configuration for myvirtualserver.com
… errors were found, which will prevent Let’s Encrypt from issuing a certificate :
Apache website : PHP is configured to run as the domain owner, but SuExec is not enabled!

I’m not sure if this is relevant, but in the previous step (enabling SSL for the site) I had to edit “/etc/apache2/sites-enabled/myvirtualserver.com.conf” and replace
VirtualHost ipv4address:80
with
VirtualHost *:80
or all the sites would point to myvirtualserver.com.

Also, before I realized it was an option in Virtualmin I went through the manual installation as far as "apt-get install certbot python-certbot-apache ".


#2

Hi,

This error suggest that SuExec might not be installed on your server.
Could you try to run the automatic script again and enable the SuExec ?

P.S. this is a VirtualMin setup error, hence you’ll actually need to seek support from VirtualMin instead of Let’s Encrypt.

Thank you


#3

I found found the SuExec virtualmin setting (System Settings -> Server Templates -> Default -> Apache Website) and it looks like it is enabled.

Is there a way of determining the name and location of the LetsEncrypt setup command that was attempting to use SuExec? One of the posts I found mentioned that SuExec will only work with commands run in specific directories.