Letsencrypt certificate was successful renew but Expires date still not change

#1

My domain is: beta.asiopay.com

I ran this command: certbot-auto renew --pre-hook “service nginx stop” --post-hook “service nginx start”

It produced this output:
Upgrading certbot-auto 0.29.1 to 0.31.0…
Replacing certbot-auto…
Creating virtual environment…
Installing Python packages…
Installation succeeded.
Saving debug log to /var/log/letsencrypt/letsencrypt.log


Processing /etc/letsencrypt/renewal/beta.asiopay.com.conf


Cert is due for renewal, auto-renewing…
Plugins selected: Authenticator standalone, Installer None
Running pre-hook command: service nginx stop
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for beta.asiopay.com
Waiting for verification…
Cleaning up challenges


new certificate deployed without reload, fullchain is
/etc/letsencrypt/live/beta.asiopay.com/fullchain.pem



Congratulations, all renewals succeeded. The following certs have been renewed:
/etc/letsencrypt/live/beta.asiopay.com/fullchain.pem (success)


Running post-hook command: service nginx start

My web server is (include version): nodejs

The operating system my web server runs on is (include version): ubuntu

#2

Hi @trungdh

checking your domain (via https://check-your-website.server-daten.de/?q=beta.asiopay.com ) there is a new Letsencrypt certificate.

CN=beta.asiopay.com
	06.03.2019
	04.06.2019
expires in 90 days	beta.asiopay.com - 1 entry

So your website is secure.

Perhaps it’s only a caching problem of your browser.

PS: But

Domainname Http-Status redirect Sec. G
http://beta.asiopay.com/
207.148.122.234 301 https://beta.asiopay.com/ 0.570 A
https://beta.asiopay.com/
207.148.122.234 200 7.833 B
http://beta.asiopay.com/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
207.148.122.234 301 https://beta.asiopay.com/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de 0.540 A
Visible Content: 301 Moved Permanently nginx/1.10.3 (Ubuntu)
https://beta.asiopay.com/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de 200 7.353
Visible Content: You need to enable JavaScript to run this app.

The last message (Status 404) is curious: Do you have a second application? Perhaps you have to install the certificate, so this app is able to use the new certificate.

closed #3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.