LetsEncrypt Certbot Not detecting IP

My domain is:
I ran this command:
certbot certonly --standalone
It produced this output:

Please enter in your domain name(s) (comma and/or space separated) (Enter 'c'
to cancel): antoniswebsite.hopto.org
Requesting a certificate for antoniswebsite.hopto.org
Performing the following challenges:
http-01 challenge for antoniswebsite.hopto.org
Waiting for verification...
Challenge failed for domain antoniswebsite.hopto.org
http-01 challenge for antoniswebsite.hopto.org
Cleaning up challenges
Some challenges have failed.
The following errors were reported by the server:

Domain: antoniswebsite.hopto.org
Type: dns
Detail: No valid IP addresses found for antoniswebsite.hopto.org

My web server is (include version):
Apache 2.4.46
The operating system my web server runs on is (include version):
Windows 10 Home 20H2
My hosting provider, if applicable, is:
I can login to a root shell on my machine (yes or no, or I don't know):
I don't know
I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
Certbot 1.12.0

I have a valid A record toward' s my web server. I have tried both public and private ip addresses. I have also tried some other authentication plugins but they do not work as well. My domain provider is No-Ip so I cannot add TXT records.
Any help would be appreciated.

1 Like

Hi @swanserquack


D:\temp>nslookup antoniswebsite.hopto.org.
Name: antoniswebsite.hopto.org

not a public visible ip address, that's only a private ip address.

A public ip address is required if you want to use http validation.

1 Like

I have changed it to my public ip and I get:
The following errors were reported by the server:

Domain: antoniswebsite.hopto.org
Type: connection
Detail: Fetching
Timeout during connect (likely firewall problem)

1 Like

And what's now your question?


is your error, fix that.


Thanks for your help. Forgot to setup port forwarding.


Yep, that's required. Happy to read you found the solution :+1:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.