Let's encrypt is not accepted by Stripe - Apple Domain verification fails

Please see below - I basically get the TLS1 needs to be upgraded to TLS 1.2 message but I am not sure how and Stripe say to contact you. I am not a developer so apologies if I am just not getting this! I hope you can help.


My domain is: baseline-tactical.com

I ran this command:

It produced this output:

My web server is (include version): Dedicloud with Plesk 12

The operating system my web server runs on is (include version): Linux - CentOS

My hosting provider, if applicable, is: https://www.unlimitedwebhosting.co.uk/s

I can login to a root shell on my machine (yes or no, or I don’t know): no

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Wordpress / Plesk on dedicated VPS

The configuration is very outdated and insecure. This is no lets encrypt problem. You want an A here https://www.ssllabs.com/ssltest/analyze.html?d=baseline-tactical.com but with your current configuration you get a F. Please ask your hosting provider to fix the issues, or move on to a other that actually care about security.

Thank you, I’ve prompted them and they’ve done updates. Would that be the reason for the reject or is there something else?

This was almost certainly the reason - Stripe has a vested interest in maintaining secure connections with modern protocols, and thus, I suspect, would block insecure protocols, which is exactly what their error message is stating.

But it’s still not working? Is this a caching issue and I need to just wait?

It’s hard to say. You need to ask Stripe what to do next.

Ok so they just wanted to know that it’s definitely the upgraded version TLS1.2 so can I say ‘yes’ to that? :slight_smile:



Thank you for your help :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.